Issue with my latest Pulse XE

  • @cope413 Received your email and I am going to troubleshoot based off what you sent.

    This isn't a heat or "constant" issue for those listening in. Both Pulses will run beautiful 3-4 hour...sometimes 12 hour prints, flawlessly as I run these 24/7. Cabinets stay at a constant 34c.

    This particular Pulse included, but every 2-3 print jobs it will "all of a sudden" (and I mean within an instant) go to crap and start destroying the print. This is not a "gradual thing". At the same time Matter Control will lock up on the print job when you try and cancel the print.

    This is not a climbing heat this will happen after multiple prints with the cabinet maintaining that temp. Again its an instant crash in the print job and the photos I attached are after only letting 2-3 layers print after the crash. So what you are seeing is not more than a few minutes (3-5 minutes) once I see it go bad.

    I know the gantry is level, will confirm the bed but I am pretty sure its level as I print parts all around it with a consistent "squish" on the first layer.

    Will verify the steppers as suggested.

    Again, I ran and still run the original Pulse XE in that same cabinet at those same temps and have done so for almost 6 months with a hundred rolls of filament through it... this new Pulse XE out of the box, just acted a little "different"...

  • MatterHackers

    I don't know what would cause the issue, but it's very clear what the issue is. In your print log that you shared you can see that the current for the Z starts at 850ma when it throws the first over-temp warning (line 25272) and drops over the course of the print all the way down to 60ma (line 199842).

    It's odd for a few reasons, but first and foremost in my mind is that the default current for the Z motors has been 725ma for a long time - so I'm not sure how/why yours is showing 850 to start.

    At 34C ambient, you're right, there shouldn't be any over-temp issue, but the driver temperature and subsequent current reduction that the firmware does when over-temp is detected is definitely the cause of the issue.

    I would expect it to be a fairly sudden failure mode, though, because at a certain point the motors simply will not have enough power to move up. I would expect it to be a very binary failure mode. It will work until it suddenly doesn't - I just don't know what that current value is because there are a lot of variables (friction of your specific machine, specific impedance of the motors on your machine, specific voltage of your power supply, etc)

    One thing I didn't mention in the email is that you should send an M502 command after flashing the firmware. This will reset the EEPROM to the firmware default values.

  • @cope413 so off your emails… you sounded like in the second, that you saw the GCode and thought it may be the stepper drivers.

    Confirmed the gantry and bed is level/flat.

    Should I just go through that process of trouble shooting the drivers? Or should I mess with the firmware still, prior to that?

    Just confirming…because I’d like to troubleshoot in increments versus throwing the kitchen sink at it all at once.

    Sounds like from this last post you seem to know the issue…based off the GCode.

    Just confirming…

    Regardless it sounds like this printer is turning out to be a “little off”…

  • MatterHackers

    Sorry if I wasn't clear. I meant to convey that we definitely know the mechanism of the failure - that is, motor current dropped low enough so that the Z motors were not able to move anymore.

    I just don't know the exact cause of that failure. Said differently, assuming that your ambient is ~34C, and that you haven't manually changed the motor currents, I don't know what would cause your drivers to throw the over-temp error and start dropping current. I also don't know how your drivers were set to 850 to start.

    Let me know if the failure mode occurs after flashing the firmware.

  • @cope413 Running tests now with the firmware updated.

    Other than the M502, is there a thermistor calibration I can/should run?

    It is now taking a while to hit the nozzle temp and what I am seeing is (with nozzle set to 263) that it climbs to 261/262 and flutters back and fourth between the two for what has been at least 5 minutes or more on both tests so far.

    I know on Klipper I can run a thermistor calibration...

    This was not like this before, so I am assuming it lost something in the firmware update.

    *In fact while I write this it has been at least 8-10 minutes of it fluttering back and fourth between 261/262 without yet hitting the 263 to start the print....going to have to cancel it or adjust the temp down to kick it off...

    Again this printer acts in no way like my original Pulse a completely different machine.

  • @cope413 Yea so the only way I can get it to print now, is to set the nozzle in the slice to a specific temp (higher than I need), then start the print and when it gets stuck fluttering back and fourth under that set temp (I have let this go on for 10 minutes at least in one test) I then need to manually bump the temp down in the Control Panel to get it to start printing....

    Here is the Terminal log of it fluttering under the set temp
    Temp not reached log

  • MatterHackers

    @damianoffthegrid Run a PID autotune.

    Send this command in the terminal

    M303 E0 S275

    When it's finished, it will spit out 3 values, (Kp, Ki, Kd)

    Write those down and enter them in the EEPROM.

  • @cope413 Ok ran it...but sorry...where and how do I access this "EEPROM"... NEVERMIND I found it....

  • @cope413 Still getting a Hardware error on heat up.

    Error reported: "Error-Heating failed, system stopped! Heater_ID:E0"

    Screen shot

    and here is the exported log

    Error Log

  • @cope413 Just getting repeats of those error logs and cannot kick off a print. Here is the last one where it started to do its bed leveling and "heated out".

    Heat error

    I was only able to get one print out of it after the firmware update today and that was earlier prior to PID autotune and that was by chance as I quickly lowered the control panel nozzle temp after the nozzle was warming up past that temp. (FYI the print was beautiful...but have tried nearly a dozen times and cannot get it to start another print without that error)

    The Print in
    PC+CF .15 layer height 40mmx20mm Cube
    *and that's a first print, new profile and after pulling the printer off the shelf, re tightening everything, re leveling.... 6 months of R&D...."dialed"


    I'm gonna give this "Lemon" another night...then its getting pulled off the shelf and this Prusa Mk3 sitting here is going up in its place. Unfortunately, while I like the first Pulse XE, and this one prints great...when it prints....I got parts to run and this thing ain't cutting it.

    Let me know any last suggestions before it comes back to you.

    NOTE: If I had to guess...the firmware you sent does not have the appropriate thermistor type w/ mosquito it seems like the nozzle is now taking twice as long to heat up n and the bed is beating it to 90c

    I don't ever remember a time...when the bed would heat up faster to 90c than a nozzle would get to 260c....

    And just an Update.... I will confirm this right now.
    The original Pulse XE on Preheat, will get to 280c at the nozzle while the bed is still halfway to 90c
    The "Lemon" Pulse XE will get to 90c on the bed and sometimes even start bed leveling before the nozzle even gets to 240c (goal 260c).

    Right when the Bed hits 90c it errors out because the nozzle didn't beat it to temp.

    That's your issue....

  • This post is deleted!

  • @cope413 and here is some more great findings and videos of these findings....

    So with this above information I attempted a Preheat with the bed down low so that it would never cool down to that temp while allowing the hotend to heat up.

    I had it originally set to 260. It climbed then flustered around 240/241....stayed there.

    I then turned it up to 280. It then started to kick in and climb again till it stayed and fluttered around 260/261.

    Here is that video
    example video

    I then set it to 300. It took a few minutes... then started to climb to 280...

    Here is that video

    Hopefully all that helps... I am about done toying with it....

  • Global Moderator

    @damianoffthegrid "The Print in
    PC+CF .15 layer height 40mmx20mm Cube" Just an fyi, if you are printing composite polycarbonate, you should never exceed a layer limit of 60% of your nozzle diameter. So if you are printing with a 0.4mm nozzle, the layer height should not be lower than 0.24mm. Layers lower than this limit can and will eventually cause excessive pressure and clogging.

  • @tinken it’s a .6 nozzle on that cube/all my production parts and machines and I run PC+CF all day n night at .15 layer height…. Prints beautifully as you can see…hours on end on complex parts with tons of retractions… 9mm at 85 mm/s to be exact on every travel move…

    But this really has nothing to do with the thread….or the current issue with this printer that we are discussing

  • @cope413 @LarsBrubaker Does not sound like anyone here can help with this faulty Pulse XE. Going to pull it off the shelf and will contact the office to see about returning it.

  • MatterHackers

    Sorry, I was traveling and don't check the forum every day.

    Without knowing what your PID values are, I can't say for sure, but it looks like that is the issue.

    What were your PID values that the autotune spit out?

  • @cope413 First calibration I ran was a bit off from the second, but the last one that I have plugged in now is
    P=9.29 I=0.41 D=53.00

  • MatterHackers

    Those seem odd and pretty far off from default and what I would expect.

    Based on the behavior in the video, try P20, I2.5, D30

    Let me know what the heating behavior is and we can manually adjust from there.

  • @cope413 if you watched the videos… the nozzle temp will only go 20c below the set temps

  • MatterHackers

    I did watch the video. That's what I based those values to try off of. Try those and then let me know the behavior

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.