MatterControl isn't opening



  • The program has done something similar to this before but I was able to fix it somehow. That might sound vague and that is because I don't know how I did it, it just worked after factory resetting my computer and reinstalling it 5 times.

    This time I have done that and I still can not get it to open properly
    0_1523140434289_Matter Control.PNG )

    Attached is what MatterControl looks like when I open it up after a few seconds. When opening, for the first few seconds the program looks normal (albeit it is frozen) but then it becomes what is seen above.

    While I have tried reinstalling I also run into this error screen that I can exit out of but MatterControl just opens up as stated above

    Error seen below
    0_1523140606153_Matter Error.PNG

    I should also state that when the program is loading, even after reinstalling, my files still exist even though everything should have been deleted.

    Any and all help would be greatly appreciated.


  • MatterHackers

    @datnewsome The Microsoft .NET error appears since your computer already has the framework. Ignore the error. Follow the steps below to conduct a new installation and see if this makes a difference.

    Step 1: Uninstall MatterControl.
    Step 2: Go to C:\Users{UserName}\AppData\Local. Under the Local Folder, search for MatterControl Folder and delete the contents.
    Step 3: Under the C:\Program Files (x86), delete the MatterControl Folder.
    Step 4: Reinstall MatterControl.



  • I would also do a reboot of the computer to take anything out of resident memory, and then do a disk defrag on a hard disk or a optimize on a ssd then do the install...



Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.