Can't export X3G - MatterControl 2.0



  • Re: No longer able to export to X3G
    Trying out MatterControl 2.0 on a Replicator 2, but I can't export a viable x3g. As soon as I click export, a blank x3g file is saved. I can export gcode for other printers just fine. Any ideas?
    EDIT: Version 1.75 will export an x3g.


  • MatterHackers

    Hey @neilferreri

    It sounds like this issue is a bit of a bug in Mattercontrol, the Dev team has been notified of the issue and we are able to replicate it. Hopefully we have a fix soon but it is in the queue.

    Let us know if you do run into any more issues, we are always looking to improve where ever we can!



  • @michael-petitclerc said in Can't export X3G - MatterControl 2.0:

    Let us know if you do run into any more issues

    I'll have to wait until there is a fix for the x3g export before I can test for any more issues.

    Thanks for looking into it.



  • @michael-petitclerc Any idea if this is being looked into?


  • MatterHackers

    This has been fixed. Please update to the latest build.

    If you are on Mac you may have to change to the Alpha channel to get the fix. It will be in release in a couple weeks.

    alt text



  • @larsbrubaker said in Can't export X3G - MatterControl 2.0:

    This has been fixed. Please update to the latest build.

    Thanks! For some reason I thought you'd secretly install the new version for me.
    😵
    I'll give that a test tomorrow.



  • @larsbrubaker Hi , I am having the same issue with the current release.



  • I am having the same issue. I have a CTC Bizer dual extruder (Makerbot Replicator clone) and while I can run the printer just fine with the current version of MatterControl by connecting a USB cable between my laptop and the printer, I can't get the software to export viable .x3g program files to an SD card so I can run the printer that way - all exports seem to come out in "gcode" format.



  • It looks like the bug still exists in the current release as well as in the alpha 2.20.4.10460, at least for WIN10. Although .x3g export is selected there is always a ._gcode file generated.



  • This issue still exsists - very frustrating. Any workarounds avaliable?



  • I've had this issue for a while now and its driven me crazy as the USB connection to my Flashforge Creator Pro sometimes seems to freeze mid print - so the SD Card *.x3g route seems to be the most reliable way for me. But I just couldn't seem to get the program too produce the *.x3g files.

    However... I THINK I FINALLY FOUND A WORKAROUND!

    Not sure if this will work for others (I would be interested to know) but here goes... So I found that Mattercontrol 2.0 only seems to fail to export the *.x3g IF it comes up with the "Possible Unsupported Parts Detected" error in the export file window. So I found if I then made sure to generate supports, it started to export the *.x3g files just fine.

    But that was annoying as there were a few times when I DIDN'T want to print with supports. So I found that if I opened the "Generate Support" tab at the top of the main window (next to the "Arrange All Parts" button) and set the "Overhang Angle" to 0, the error went away and I could export unsupported parts.

    Like I say, no idea if this will help anyone else, but thought I would share in case it does!


  • MatterHackers

    I will look into this over the weekend. Thanks for bring it back up.


  • MatterHackers

    Thanks for describing this error in more detail. The tip about support really helped. This is now fixed in the Alpha version. Please let us know if this is working for you.

    Thanks again.



Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.