K8200 stepper issue

  • I have an old Velleman K8200 printer. It used to run fine and I had no troubles with the x or y movement. As of today, the x stepper motor just jitters when given a move command.
    Here is what I have done to trouble shoot:

    1. Checked the problem with MatterControl (latest) and Repetier (old, but know to work). Both software produce the same problem.

    2. Unhooked the x drive belt from the stepper gear. Problem still persists.

    3. Built a stepper motor / stepper driver tester with an Arduino. Used another stepper and tested all four stepper drivers. They worked perfect. Pulled the x stepper motor off the K8200 and tested. It ran fine with the stepper driver that it used in the printer.

    4. I adjusted the voltage in all the drivers to between 0.55V and 0.6V.

    5. Put everything back in the printer and checked again.

    The only thing I can think now is that the mainboard has an issue. I’m going to check what I can on it.

    Any thoughts about this?

  • MatterHackers

    If the motor is shaking but not moving it's an electrical problem. There is a bad connection on one of the motor wires. Check the connectors and try jiggling the wires.

  • Thanks for the reply.

    When I did step 3 above, I used the wiring from off the printer.
    Tried again and the motor and wiring work fine.

    I am looking a the main board. 5V supply is good, 15V motor supply is good.
    I think I am going to try and look at the DIR and STEP pulses next.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.