Hot end temperature controls missing on MatterControl 2.19 with TRONXY C5

  • Hi,

    Just got my 3D printer...a TRONXY C5. I am still printing calibrations cubes to try and get it all working correctly and printing well, but I am having trouble with the hot end. I am using the newly released MatterControl 2.19 but there are no hot end temperature controls visible. The heated bed temperature control is on the top right...shouldn't the hot end temp control be there too?

  • MatterHackers

    You should find both the hotend and the bed controls both at the top right of the main display and within the controls tab.
    Here is a gif I made that should be the same as what you are seeing on your screen.

    heating controls

  • Hi Lars,

    Thanks for taking the time to reply, I really appreciate it. Your gif shows exactly where I thought the hot end contol should be, just as the manual indicated. I seem to be missing both the 'Hot end' control up on the menu bar and the 'Temperature' settings on the 'Controls' tab. Please see my screenshot below:


    Any thoughts on where I have gone wrong?

  • Interestingly, when I downgrade to MatterControl 1.75 I do have the hot end controls, but they are gone when I upgrade to 2.19....?

  • Click on printer and then check your extruder count make sure it says 1

  • Hi,

    I've just solved the problem!

    I had to choose 'Other' when selecting my printer because Tronxy C5 was not one of the available templates. The default settings for MatterControl 2.19 had the 'Other' printer identified as an SLA printer. This didn't happen in earlier versions. So when 'Printer is SLA' was de-selected the extruder temperature controls appeared.
    Hopefully this will improve my print quality issues.

    Thanks for the help though!

  • MatterHackers

    Thanks for letting us know what fixed it. I will make sure we address that right away.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.