Exporting to SD Card

  • Hello,

    I'm trying to Export imported 3D Object .stl 130x105x88mm model, size 3,04 MB with 0.1 Layer Thickness, Fill density 25% and supports added in MatterControl application version 2.0 to USB Drive SD card 16 GB, File system FAT32 on Windows 10 Pro OS is a Intel(R) Core (TM) i7-4700HQ CPU @ 2.40GHz RAM: 12,0 GB 64-bit Operating System, x64 based processor.

    To export less size models it requires about 3-4 minutes for Slice and Export, but with this model it seems impossible. I've waiting for half hour to end slicing and then for half hour finally just to end task, because during export OS was slowed till freezing, including web browser and zero Export progress. Task manager shows 97% of memory using and 9814,2 and 0,6 MB/s RAM for MatterControl. I've ended task without result

    Any advice, guide or example would be helpful

  • What worked for me at times was to write it to the local HD and then copy the G-Code file to the SD card. Also there were some versions where the slicer just went away at a certain layer number. So the protocol for me with MC to export to sd card with a good chance of success is as follows

    1.) Slice it to make sure the slicing process will complete if it does in layer mode you will see the layers. If you don't try a lower resolution (0.2) if that works check your version and see if you need to update if not let MH know

    2.) if it slices write it to a local hd.
    3.) open the Gcode file and look for "succes" Somewhere at the end it says "MC completed successfully" or something similar - that changed with versions hence just the first part of :successfully. If it can find that then delete the gcode file and exit MC and go back to step one
    4.) copy the file to your SD card

  • @mpirringer


    I've tried to slice model to PC hard drive directory, then copy it manually to SD card, seems like it is not only SD card problem, it freezes whole OS 95% of CPU and does not completes process, I am forced to end task, also with difficulties because everything hangs

    Then I've connected printer to PC, to print directly from MatterControl which is .exe MatterControlSetup- I guess, but result is same, everything hangs and process of slicing stops on number shown in image below after half hour of slow progress with OS freezing, finally without result, it seems impossible, not to mention that if after slice should start exporting, which does not shows even 1% of progress with SD card, and not reached completion of slicing with saving to hard drive or start print from matterControl, and all the same with Layer Thickness 0.2 except first time it passes slicing process relatively quickly, and then begins it again with same behavior as described above instead starting export

    Now, I'm trying to figure out, how to set the model from Cura to print Nylon X with Pulse XE correctly, because I'm not able to do anything with MatterControl:

    alt text

  • I suggest you send the STL to Matterhackers. It also could be that there is a problem with the STL. I'd be interested to know if cura slices it.

  • @mpirringer

    Cura processes it in seconds, I've already printed this model with another printer from Cura file, but I'm not sure if I can start it from Pulse XE.

    I've saved .stl as from part, despite that it is already a solid form, also as simplified form from assembly, which makes it solid if there is some intersections or anything else, but it is same behavior in both case, impossible to get file for print, to SD card, to PC drive or from application with USB

  • I have never tried to slice with cura but I slice with slic3r. and here is what I did
    1st set up the printer (bed dimensions etc.)
    2.) you can copy the start, end code from MC control into Slic3r and probably cura.
    3.) IDK if cura has a bed leveling feature (slic3r does not) if it does turn it off.
    You can set a Z offset if you want. And the filament and print settings sb pretty straight forward like setting layer height and width and temp and cooling you probably can copy most that stuff from MC.
    4.) slice it and save the gcode to a file .
    5.) load gcode into MC. Sometimes nothing shows but it prints anyway if it tells you how long the print will take. At this time it does not matter much what your settings in MC are as it will use the gcode and just add the bed leveling data. Works great for me as long as the gcode file is ok. (I had one odd happening where my pulse got confused and went into slow mode sending back "busy processing" messages but that was one print in 2 months printing pretty much 24/7.

    This way too you can probably use some of the features cura has and mc has not. As I said I never sliced in cura. When I ran into problems with MC I picked slic3r simply cause I read an article about the advantages of volumetric printing and it featured slic3r. And boy what a difference. I will continue slicing with slic3r for at least as long until MC supports volumetric printing. I think it could be particularly useful on the XE if you print with a nozzle >= 0.8mm and layer heights >0.2 depending on material I did a video on my youtube channel about that

    Happy printing

  • Oh at the time you load the cura file into MC you can either print it from MC or save it to a different gcode file with the bed leveling added by making sure the bed leveling is checked when you export it

  • @mpirringer

    Thank you for answer!

  • Do you have a link to that file ?
    I'd like to look at its topology.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.