MatterControl won't connect with Printer

  • Hi,
    We've been having some problems with our Tronxy X3S since yesterday. We flashed the firmware last week and it seemed to work well after that. But My boyfriend was at a lan-Party this past weekend and after all the unplugging and then replugging everything back in when he got back home the Tronxy won't connect to MatterControl over the USB. He also ran a Windows 10 Update over the weekend. We can see the Printer in the device manager.

    We have tried,

    • plugging the Printer into every USB port
    • deleting unused COM ports
    • made sure all drivers were installed and up to date
    • flashing the firmware again,
    • adjusting the baud rate
    • We've tried older versions of MatterControl, Cura, and Repitier Host (none of which connected to the printer)

    Both Manually and auto-detect simply say Connecting... for forever. We haven't recieved an error message. We are at a loss and getting extremelly frusterated. We can see the driver details on the COM port and it all seems like it should connect. Has anyone else experienced this? Or have an idea what we could try?

    Thanks for your help in advance!
    Jenna and Philipp

  • MatterHackers

    Hey @zallon

    So I have seen at least once where the COM port has the driver loaded up but it cannot establish the connection. I have heard that if you plug the printer into a COM port and locate the port (Lets say COM3), from there unplug the printer and the control board may still be available, from there you can uninstall the driver. Then restart the computer and the printer, once everything is back up you can start Mattercontrol then once it is up plug in the printer and turn it on. This may establish the connection for you.

    We know from testing a few other slicers that the issue is with the computer so it has to be the COM port is being saved with incorrect information (that is me as a simple person explaining networking). Lars might be able to explain this one a bit better than I can.

    Give it a shot and lets see what happens.

  • Hey @michael-petitclerc

    Thanks so much for your reply. We just attempted your solution but sadly to no avail. If you know someone who might be able to help we would really appreciate it. We can always print with the SD card, but its not the most efficient way.
    We will keep trying new things.
    Thanks again

  • MatterHackers

    I do not believe it but I did not even ask, have you checked your Baud Rate recently? That might explain a thing or two...

  • Although this may be a bit late, I had a similar issue with a failure to connect. The issue was Baud rate.

    Dave J

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.