Mattercontrol and Bltouch stop/starts

  • Just installed and set up a 3Dtouch on my home-built Prusa. I can get ABL to work well but printing has become a problem. Each print starts then stops every few seconds and then continues. Having checked the Terminal, the motherboard is running an M119 every so often and reports the endstops back to the PC. This appears to coincide with the print stop/starting. The setup worked fine with the original Pinda and steel sheet, but I wanted to change it to a textured glass for better adhesion. This seems to be unique to Mattercontrol as I have tested an identical print with Cura as the host and it prints straight through without stopping.

    Tech info:

    Prusa Mk3 clone, 3Dtouch, BTT SKR1.3 motherboard, Marlin 2.1, Mattercontrol (slicer)

  • Global Moderator

    @focussys Could you post your gcodes please. And are you running your printer from USB?

  • As requested, many thanks. I have been running from PC direct through USB for many years.

    G21 ;metric values
    G90 ;absolute positioning
    ;M82 ;set extruder to absolute mode
    M107 ;Fan off
    ;M420 S1 ;recall bed mesh
    ;G90 ;absolute positioning
    G1 X0 Y0 F3000
    G1 Z0 F500 ;Home
    G1 X70 Y2 Z0.2 F3000 ;move to start of purge
    G92 E0 ;zero the extruded length
    G1 X180 F3000 E15 ;extrude 15mm of feed stock
    G1 Y5 Z1
    G1 X0 Y5 Z1
    G92 E0 ;zero the extruded length

    G91 ; relative movements
    G1 Z20 F5000 ; lift nozzle
    G90 ; back to absolute
    G1 Y200 F6000
    M104 S0 ;Heater shutdown
    M107 ;Fan off
    M84 ;Disable motors

  • Global Moderator

    Did you change the firmware from pinda probe to BLtouch probe?

  • Global Moderator

    MatterControl may be adding something to your gcode... @LarsBrubaker

  • Hi Tinken, thanks for coming back. Yes I have modified Marlin 2.1 for BLtouch. The probe triggers correctly on ABL as well as G28. It prints perfectly using Cura 5.0 usb connection. It only stop/starts when printing directly from Mattercontrol. I have rolled back to older versions of Mattercontrol and all exhibit the same issue.

  • @tinken It appears to send an M119 to the printer at around the same time as the pause in the print. Is this likely to be causing the motherboard to stop printing whilst it sends a report on endstops then continues printing?

  • Global Moderator

    @focussys Seems like there might be some setting that needs to be adjusted. I use MC everyday, but I am not familiar with this issue. I will continue to help to solve this issue. Lars is the lead creator and maintainer of MatterControl. He will see this post when he logs in and respond to the issue.

    Please join us on Discord. There are also members there who might be able to diagnose your problem.

  • Many thanks for the feedback. I would not like to stop using Mattercontrol as nothing else comes close in performance.
    Can you send an invite to discord as I cannot find you there?

  • Global Moderator

  • @tinken Solved. 'Has Filament Runnout Sensor' was set in Hardware when not set in printer firmware. This resulted in MC stopping for the trigger.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.