Error when opening MatterControl.

  • I'm getting this when starting up MatterControl. Anyone seen this error and know how to solve?

    I have tried uninstalling and reinstalling.


  • I got it figured out. Had to just manually remove the Local/AppData/MatterControl folder. And it is working again.

    Something went screwy. I will keep an eye out for any possible causes.

  • MatterHackers

    Thanks for the info. We'll look into that message and see if there is something obvious. I'll also check the crash reports.

  • I believe I may know what happened. Once I realised that MC was able to handle quite a large scene of models better than any other editor I have tried, I have been probably pushing the limits. I had done an update with one of these scenes opened up. After update, it tried to reload that particular scene, and I believe locked up. I Force closed it, and I think it caused some data corruption. It's the best cause I can come up with. When I did an uninstall, it did not remove that particular local director, so when I reinstalled regardless of which version of MC, it continued to read from that local directory causing the same error to pop up. Once I realized that directory existed and removed it, all was working perfectly again.

  • MatterHackers

    That's great to hear. And we do have an open issue for dealing with this better (closing the open tabs if we can't load).

    I'll try and bump that up the list so no one else has to learn this the hard way :).

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.