Serial port permission denied Ubuntu 20.04



  • I have installed MatterControl 2.0 on an admin account successfully on a new laptop running Ubuntu 20.04
    Whenever I attempt to set up my printer with MatterControl, I get the alert saying permission denied and that my account needs permission to access the serial ports.
    I used the recommended

    $ sudo gpasswd -a $USER dialout

    command as well as similar commands found online. I have confirmed my account does indeed have permission to access the serial ports now, and I did log out and back in, but MatterControl still comes up with this permission denied alert. I even tried uninstalling MC, confirming port permissions, and re-installing MC, but the alert persists.
    Any direction will be greatly appreciated!



  • I have not tried MC in Ubuntu yet. But I can offer you a few thoughts.

    If you run the following command, does it display the group was added?;
    $ id

    Also found this post about modemmanager causing problems with dialout.
    how-do-i-allow-non-root-access-to-ttyusb0

    Other thoughts would be; try loading the software as root/adding user to root group/allowing login as root
    (I understand security implications but just thoughts for troubleshooting)


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.