Probe no longer "talking" to Mattercontrol



  • So first I have lost the filament out signal on my printer and today I go to level the bed and the nozzle drops to the bed and then attempts to go through the bed. Finally get things back on track and go into control and I can no longer extend or retract the probe using the macros to test the probe.

    When I reboot the printer the probe clicks in and out three time and the light is on. So what now, bad probe (no it hasn't been snarled or abused by filament wraps).

    Anyone from Matterhackers alive and reading this forum?



  • So the secret to repairing this issue is:

    1. Request support by email from MH
    2. Realize they are swamped and start out on my own
    3. Dismantle Hot End, pin-out probe harness with multi-meter - OK
    4. Google for ways to test probe with multi-meter - none found
    5. Order new probe and harness
    6. Reconnect existing probe and test one more time - Probe now responding to extend and retract commands
    7. Sigh heavily
    8. Reassemble hot end and test probe at each step - Probe working
    9. Clean up harness and nozzle, check probe - Still working
    10. Put printer back to work.
    11. Congratulate yourself on having a spare probe and harness on order because you never know when you might need it.

    If there is a way to test the probe with a multi-meter I would be glad to see it. It's back in action but I have no idea why.



  • Well I jumped the gun on this one, the probe responded macro commands right up until I ran a bed level calibration routine. It heated the bed to it's target temp and then attempted to ram the nozzle through the print bed..

    The probe no longer responds to macro commands from Matter Control.

    I went to the z offset calibration (big mistake), it homed then centered, bounced the probe three times as normal and then I went through the steps to calibrate the z offset.

    It now clogging the nozzle when trying to print do to basically riding on the bed surface, I have tried to nudge it up now several steps but still no joy. I guess I will wait for MH support to get in touch.

    Sigh.



  • It always bugs me when people as for advice and then never return to inform the forum of what the fix was so here goes.

    Received a new harness and probe today, started with the probe and no response from the macro tests to extend and retract. So ran the new harness to the old probe and it responds to the commands, well I have seen this before.

    Temporarily looped the harness in place and tried to calibrate the bed level and lo and behold it worked, I learned the first clue to proper operation is the probe extends on the way down, something I failed to note before so if it doesn't extend, stop it NOW or it will try and drill through the print bed.

    So I have an intermittent break in the old probe harness, it must be a small break that is making contact when the harness is in a specific spot...like the center of the bed for z offset calibration. Wires break over time, at least it wasn't the motherboard..

    Now to figure out how to add the new harness to the existing wire bundle.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.