When I print it keeps overriding my hotend temps

  • I have my slicer and printer nozzle setup in mattercontrol to print first layer at 240 then switch to 235. But when I click on print, it just gets stuck at 205 for some reason. And unless I physically go over to my printer and change the nozzle temp manually it just sits at 205 until it's done.
    alt text
    I've tried figuring it out, but I just can't find the answer on my own.

  • Check your startup gcode you should have something like a
    M109 S[temperature]
    M104 S[temperature]
    in there and then something similar in the layer change code I don't have the MC variable name list handy but you dould find the other layer code variables by calling support

  • How strange, I've had my start Gcode the same as when I was using repetier-host, but changing it from: "M104 S[first_layer_temperature] ; Extruder (no wait)"
    "M104 S[240] ; Extruder (no wait)"

    Seems to have fixed it. Weird. Thank you for the help!

  • Everything inside a [] is considered a variable of MC. So M104 S[240] might even get dropped as there is no variable "240" the proper syntax is M104 S240 the [first_layer_temperature] means replace the whole thing including the [] with the MC variable "first_layer_temperature" which you set in the UI. Make sure all of those parsing instructions produce valid GCODE you can export it to a file and then inspect it - to see valid gcode google "gcode marlin" most of those commands are valid for most printers using marlin

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.