MC does not export gcode with the auto bed level feature checked.

  • I have (2) Pulse XE's and updated MC to 2.19. Even with the nozzle and bed calibrated, when I export the gcode for my print, it does not export with the auto bed leveling (feature checked). At some point, the MC gcode export feature ceased to work properly. Additionally, when I try to tune the Z-offset on the printer to correct the nozzle print height, that does not appear to work. FYI, please fix the gcode export function before trying to add features to MC. I would like to use the printers as standalones through the SD card function. Thanks in advance.

  • I got 2.19.6. something and it works - its slow but it works at least when I save the file to the desktop. I tried it with both a Gcode file from SLIC3R and one i sliced with MC. Now on the Z-offset I am with you that is a mess. The zprobe offset sometimes works in MC. the One on the Vicky does not seem to work at all but that is not a MC problem that seems to be a firmware problem its one of the reasons printing from an SD card is quite problematic at times and also not very efficient as if I print something today there is not guarantee the bed is leveled the same tomorrow so if you need to relevel you need to write a new gcode file for the same part plus if the layer adhesion is off you are writing another file with another offset again. And there won't be any updates to the firmware. I reported quite a few bugs there and have not got anything on that in a year I do print a lot with my pulse and I can tell you - SLICE with SLIC3R and then run it through MC and run it tethered cause other things don't work with the SD card either. Like filament runout - if its working at all - and power resume - if its not a weird case - and you can sometimes recover a print with MC but IDK a single way to recover anything when printing from SD. at least not with my C232

  • Oh one more thing - I had problems writing to SD card directly so when i print from SD I always save to a folder on the C drive first, check it as sometimes it stops half way through - make sure you have the end code where it turns off the bed etc, then I use the OS to copy it to the SD card. Try that

  • @mpirringer I always copy the file to the SD, thanks for the suggestion though. The Z offset has become a problem that shouldn’t be. I calibrate the nozzle height, level the bed, export the with the auto bed level feature checked .. and still no success. This wasn’t a problem with MC since I started using it when I bought the printers last August. I can’t understand why the updates are inconsistent with this issue. When I print with MC running, I have no problems with the Z offset. I would like to use the printers as standalones.

  • make sure you do a re-calibration of your bed leveling .I am using the latest stable version and have not experience this trouble.

  • @richmarbury stated in the post

  • @tinknocker I suggest you call tech support on that. Maybe they have a solution for that. I would like to know if you get the SD printing working right cause that might help me too. For now I have dedicated an old laptop for that to run it tethered as the printer is very busy printing for the school and there is little to no time to mess around and experiment

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.