Another problem arises.

  • I can move all axis's manually, that includes extrusion, but when I try to print it will not extrude, any idea why this should be.

  • What you mean "move manually" like send a Gcode to the motor or take it in your hand and move it? If the motor turns and it does not extrude it is usually slipping so the gears that move the filament are not tight enough or there is a blockage. You can use something with a terminal like MC and type in something like G1 X(YZE)nnn Fmmm etc to test it and make sure you have properly selected either absolute or relative addressing. So for example if you issue G1 E50 F300 it might move and the 2nd time it wont cause you are in absolute mode and the controller says "I am already at 50 so I don't have to do anything" so in which case you got to go to relative mode

  • By manually I mean to make the moves via the jog buttons, everything works as it should here, the problem arises when trying to print, all axis work accept the extrusion nothing moves,it's as if it is not receiving any gcode for that.
    It all worked fine the day before, I tried to print with simplify 3D after that the problem started.

  • Go back to what you had before. It could be a problem in the start code. I also would open a terminal window and type in the following (ignore after ; as that is the comment to tell you what it means. It should verify that its processing gcode fine

    G28; Go home
    M109 S220; heat hotend to 220 - assuming you want to print at 220 otherwise whatever temp is needed to melt what you have loade
    G92 E0; Reset extruder
    G90 ; Go absolute coordinates
    G1 F1200; Set speed to 20mm/sec
    G1 X100 Y100 Z100 E50 ; Move to position x100 y100 z100 and extrude 50mm of filament
    You can follow that by a G92 E0 again to reset the extruder. now 100,100,100 should be safe as you say you had a 300x300x300 build volume but you can use any other x y z coordinates that just will move all three axis and the extruder I also would turn the printer on/off before I do that to make sure there are no other things "stuck" in there If that works then your printer works and you have a slicing problem. But from what I suspect is that at some point in the slice a g90 is set to set absolute address - maybe in the start code for the printer and then the slicer somehow thinks its relative. If you want you can type that gcode in a text editor and save it to "test.gcode" and load it to your SD card if you can't run tethered to usb. If that does not help post the first 30 or 40 lines of gcode (not counting anything that starts with ;

  • Ok, that really just did the same as I did by jogging,
    here is the first part of the Gcode.
    M104 S200
    M140 S60
    M190 S60
    M109 S200
    G1 Z0.1 F5000
    G92 E0
    G0 F4800 X213.04 Y90.62 Z3.73

    I no this happens no matter which file I tried, so it has something to do with the program somewhere.

  • I just tried slicing with Slic3r and used it in Matter control and it is printing OK, so it does seem as though it is a problem in possibly a setting somewhere or the in the slicer.
    Also something else I noticed, the hole shape is far better.

  • I use Slic3r and MC. You cut the list of gcode off up there before the first extrusion, extrusions haveG1 E and probably some x and y or Z If you want to dig into it you can do the Gcode in SLIC3R that works and the one in S3D and compare them But glad its working for you. Now my code was just a "jogging" code used to proove that your printer works and you had a slicing problem but you know that by now

  • Turned out to be a gliche in the data file, cured this by deleting the AppData\local\MatterConrol data, and reinstalling the program, all is now back to normal. Thanks for the help.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.