Unable to export to x3g file format

  • Hi All,

    Looking for some help, just installed and setup MatterControl 2.0 ( for Windows 10 to be used with my Makerbot clone CTC Bizer using sailfish 7.6. Unfortunately each time i slice and try to export it as .x3g it instead exports as ._gcode. I'm I just being silly and missing something or is there a problem I'm not seeing.

    Any help is greatly appreciated.

  • MatterHackers

    Hi @Odin21100,

    I just tried setting up a CTC Bizer in build and it seems to be working as expected. I saved the export file to my downloads folder. It may be that the confusion is it generates both a ._gcode file and an .x3g file.

    Do you by chance see both files?

    Hope this helps.
    If not we will definitely investigate further. 🙂

  • Hi there @LarsBrubaker,
    I also have this same issue and have been trawling the forums to see if I can find a fix, though alas, it seems only a few people have been having this issue.

    I downloaded MatterControl 2.0 a few days ago and began messing around with dual colour prints, exporting as .X3G for my CTC Bizer, however it has recently began to only export ._gcode files. I've tried numerous times to fix this issue by:
    -Creating a new printer profile,
    -Uninstalling and reinstalling MatterControl,
    -Switching to the Alpha version from Stable,
    -Even manually cleaning my registry of MatterControl files.

    I noticed that my software still seems to save my preferences and profiles however, even after registry cleaning and instillation, which makes it difficult to diagnose whether it's a corrupted file or not. Could you perhaps guide me on how to do that?

    The only thing I can think that may have triggered this behaviour is attempting to export a sliced file to .X3G that wasn't placed on the bed properly. I was trying to test whether MatterControl was using my Z axis correctly and attempted to slice something floating 10mm above the bed, however this didn't produce a .X3G file and the software never has since.

    Thanks, RpiBox.

    Edit: I should note I am running on Windows 7, not Windows 10.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.