Subtract not working

  • I’m also am having the same problem, imported a design from thingverse, tried to modify it using subtract and nothing happened
    Win 10

  • Love MatterControl... But there is definitively some issues when subtracting. In my case, when you try to subsequent subtract more than one time the same element, the item disappears or the application status bar gets stuck. If you try to subtract from a mid complex item, same issues happens. 😞

    I tough that maybe have to do with objects that are grouped, but even when they are flattened, its impossible to make it work in 98% of the cases.

    Code team... please solve this issue.

  • This is driving me nuts. Trying to Subtract a shape from an ongoing design and the whole thing vanishes when the subtract process completes. Have been through every variance I can think of, but no dice. So long, Matter Control, it was fun while it lasted...

  • I have found a simple solution to this problem. I am surprized someone has not found it before now.
    Try this and it will work everytime:

    1. Lift all items off the build plate before clicking Subtract.
    2. Click the box or boxes for the item you want to Subtract.
    3. Click Update
      Wa La

  • @dennolan I just made an account to confirm this 100% works, I'm a new user currently without home internet and I downloaded this to replace tinkercad, I was about to just move on to the next program until I read this. Thank you!

  • Is this software still supported? I'm having this bug and if it's been a year for a much needed tool in an editor. I have been customizing for hours just to find out it's wasted.

  • Hi,
    I found it working with all standard primitives. But it will not work, if you import an object and you try to subtract this object.
    In my case I wanted to subtract an imported STL screw thread from a standard sphere. It never worked.
    Subtracting a standard cylinder does work immedeately.
    Is this simply a bug or does only work with MatterControl primitives?
    How can this be solved?

    Kind Regards

  • I’m a newbie but find same issue on MacBook with newest is, but it works okay on Win 10 laptop.

  • @dennolan Thank you for figuring this out! I can't tell you how many models I was recreating from scratch to regain the functionality of subtracting. Thank you! thank you!

  • I updated this week, started designing a thing and found that I cannot subtract objects after I have saved shut down and started back up. I can do simple subs but not the complex ones that "worked just fine" before I saved and shut down. Previous version had the same problem. I like this software, I was thinking about getting it but not if its going to be so buggy. I have a day in this design and now I cant do anything to it, even after having multiple project files to keep things simple. Window 10 64 I7 32gig 3tb 2080.... So frustrating.. Yes, I even lifted off the grid because most of the time subtract leaves parts if it is sitting on the surface. I mostly just want to add to the list of confirmed "subtract does not work properly" cases.

  • Same thing here, found this as I was pulling my hair out trying to figure out what's wrong with either my computer or how I was doing it. The lifting trick didn't work for me similarly have put a few days into a design (probably the most complex thing I've built so far) and now can't finish it. It just hangs on "Split faces 2" for me. Does anyone have a solution? Are there other good programs out there that would read the .mcx files??

  • Same issue still with complex models in 2.21.10.

    Simple objects work though.
    Lifting up from build plate makes no difference sadly ...

    Does anyone have a solution/ is this getting worked on?

  • MatterHackers

    We do continue to work on this. It is a very complex problem but we hope to have an improved solution soon.

  • Hi,
    I have the same issue with software version
    simple project, subtracting a cylinder from a cube, and both objects subtract.
    Does anyone have any pointers, or can I revert to an older software version that worked?

  • MatterHackers

    Regrettably, there is no older version of MatterControl that produces better results.

    I have often teased that we are working on a new version (which we have been even though it's been slow going).

    The new boolean logic is now working quite well and should be in the next release scheduled for mid December. This new version is radically more robust against lots of geometry and we are confident you will be able to get the results you are trying to achieve. This is also the first version of the improved boolean code that works on Mac. So if you were on Mac, we did not have a good solution. This new solution is cross-platform and is very good.

  • MatterHackers

    There is a new Alpha version available that uses the improved subtraction solution. It should be dramatically more robust. If you have errors I would love to see them.


    alt text

  • Global Moderator

    I'm on Linux at the moment, but I will spin up a Vm a little later and try everything out. Thanks!

  • Global Moderator

    Works perfectly, was super easy to subtract!

  • This is also not working here. I've tried complete uninstall and reinstall, and it's still not working.

  • Global Moderator

    @djohnavid021 I need a little more information to go on than just stating its not working. Did you select two or more objects before subtracting? Did you then select the item you wished to subtract?

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.