Subtract not working



  • Hi

    I've tried Windows 10 64-Bit and Linux Ubuntu Mate 18 64-Bit versions and I can't get the Subtract to work in either.

    The work around I have had to use is to create the holes I need with tubes and build the rest of the structure around it.

    Is there anything I can do to help find out why the Subtract function isn't working?



  • I’m also am having the same problem, imported a design from thingverse, tried to modify it using subtract and nothing happened
    Win 10



  • Love MatterControl... But there is definitively some issues when subtracting. In my case, when you try to subsequent subtract more than one time the same element, the item disappears or the application status bar gets stuck. If you try to subtract from a mid complex item, same issues happens. 😞

    I tough that maybe have to do with objects that are grouped, but even when they are flattened, its impossible to make it work in 98% of the cases.

    Code team... please solve this issue.



  • This is driving me nuts. Trying to Subtract a shape from an ongoing design and the whole thing vanishes when the subtract process completes. Have been through every variance I can think of, but no dice. So long, Matter Control, it was fun while it lasted...



  • I have found a simple solution to this problem. I am surprized someone has not found it before now.
    Try this and it will work everytime:

    1. Lift all items off the build plate before clicking Subtract.
    2. Click the box or boxes for the item you want to Subtract.
    3. Click Update
      Wa La


  • @dennolan I just made an account to confirm this 100% works, I'm a new user currently without home internet and I downloaded this to replace tinkercad, I was about to just move on to the next program until I read this. Thank you!



  • Is this software still supported? I'm having this bug and if it's been a year for a much needed tool in an editor. I have been customizing for hours just to find out it's wasted.



  • Hi,
    I found it working with all standard primitives. But it will not work, if you import an object and you try to subtract this object.
    In my case I wanted to subtract an imported STL screw thread from a standard sphere. It never worked.
    Subtracting a standard cylinder does work immedeately.
    Is this simply a bug or does only work with MatterControl primitives?
    How can this be solved?

    Kind Regards
    Ewald



  • I’m a newbie but find same issue on MacBook with newest is, but it works okay on Win 10 laptop.



  • @dennolan Thank you for figuring this out! I can't tell you how many models I was recreating from scratch to regain the functionality of subtracting. Thank you! thank you!



  • I updated this week, started designing a thing and found that I cannot subtract objects after I have saved shut down and started back up. I can do simple subs but not the complex ones that "worked just fine" before I saved and shut down. Previous version had the same problem. I like this software, I was thinking about getting it but not if its going to be so buggy. I have a day in this design and now I cant do anything to it, even after having multiple project files to keep things simple. Window 10 64 I7 32gig 3tb 2080.... So frustrating.. Yes, I even lifted off the grid because most of the time subtract leaves parts if it is sitting on the surface. I mostly just want to add to the list of confirmed "subtract does not work properly" cases.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.