Subtract not working



  • @larsbrubaker
    Thank you for your quick reply!
    I can understand that it wouldn't work with some geometry-
    But it's not working under any circumstances (e.g. even subtracting a cube from a cube) while it works perfectly fine from another computer.

    So it's a generic problem not related to the type of mesh/geometry, and rather random (given that it does not occur on a few machines with the exact same configuration).

    The old beta version works fine on all of the machines but does crash at times.



  • Same here.
    I am a brand new user and working on my first project.
    I was trying to subtract a slope from a rectangle and it wasn't working and thought I must have been doing something wrong, so I opened a fresh project to experiment with to figure it out.
    Even on a clean slate, with 2 primitive cubes, with no adjustments, just 2 bog-standard 20x20x20 cubes straight off the menu, it can't subtract an overlapping corner.
    All it does it groups them, well, double groups them actually. I have to ungroup, then ungroup again to separate them.
    I tried to save the STL and load it into 123D (gasp) and cut it there instead, but the entire project ends up grouped as one object and 123D cant ungroup it, so...... no luck there either.
    Looks like I am going to have to start from scratch in 123D and maybe check back on MatterControl once its a bit further along in development.
    I'm running on Win10, with an Intel i7.
    I really hope you can sort it out.

    On a side note, I couldn't get it to connect to my printer, a cocoon create touch, which is a rebranded Wanhao duplicator i3 plus, which is essentially a commercial Prusa RepRap.
    It just continually says no printer found even though I can see the ramps listed in the system devices, and Cura connects fine.
    I even tried manually selecting the COM but it still says there is no one home.
    But the subtract issue is WAY more important, I can always us an SDcard.

    P.s. 1.6k views on this topic, so I would say there are a LOT of people having this issue, not just the few who have posted.



  • Hi

    I've tried Windows 10 64-Bit and Linux Ubuntu Mate 18 64-Bit versions and I can't get the Subtract to work in either.

    The work around I have had to use is to create the holes I need with tubes and build the rest of the structure around it.

    Is there anything I can do to help find out why the Subtract function isn't working?



  • I’m also am having the same problem, imported a design from thingverse, tried to modify it using subtract and nothing happened
    Win 10



  • Love MatterControl... But there is definitively some issues when subtracting. In my case, when you try to subsequent subtract more than one time the same element, the item disappears or the application status bar gets stuck. If you try to subtract from a mid complex item, same issues happens. 😞

    I tough that maybe have to do with objects that are grouped, but even when they are flattened, its impossible to make it work in 98% of the cases.

    Code team... please solve this issue.



  • This is driving me nuts. Trying to Subtract a shape from an ongoing design and the whole thing vanishes when the subtract process completes. Have been through every variance I can think of, but no dice. So long, Matter Control, it was fun while it lasted...



  • I have found a simple solution to this problem. I am surprized someone has not found it before now.
    Try this and it will work everytime:

    1. Lift all items off the build plate before clicking Subtract.
    2. Click the box or boxes for the item you want to Subtract.
    3. Click Update
      Wa La


  • @dennolan I just made an account to confirm this 100% works, I'm a new user currently without home internet and I downloaded this to replace tinkercad, I was about to just move on to the next program until I read this. Thank you!



  • Is this software still supported? I'm having this bug and if it's been a year for a much needed tool in an editor. I have been customizing for hours just to find out it's wasted.



  • Hi,
    I found it working with all standard primitives. But it will not work, if you import an object and you try to subtract this object.
    In my case I wanted to subtract an imported STL screw thread from a standard sphere. It never worked.
    Subtracting a standard cylinder does work immedeately.
    Is this simply a bug or does only work with MatterControl primitives?
    How can this be solved?

    Kind Regards
    Ewald



  • I’m a newbie but find same issue on MacBook with newest is, but it works okay on Win 10 laptop.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.