Subtract not working

  • I'm on, and subtract isn't work for me. On my designs, or imported designs. It's been probably 3 maybe 4 updates since it worked. It act like it's doing the subtract, ie. The pop-up window in the upper left shows it's modifying, but then nothing changes. If I slice it, both objects are where they were before the subtract. The other Boolean operations seem to work as they should. Any help would be appreciated.

  • MatterHackers

    Hey @67exec Would it be possible for you to drop me some screenshots of what is happening? This is something I am interested in finding if it is a bug or what is going on. I have heard of this happening before but I have yet to get information that would assist the Dev team in finding the root cause.


  • Not working here either, except that substract is just greyed out.

  • A Google drive video link is the best that I can do.
    link text
    It's 1:34 minutes long, and at the 1min mark you can see the dialogue box flash in the upper right corner

  • MatterHackers

    Hey guys,

    Make sure you are all on the current build of I am unable to replicate the issue on this end, it seems to be running fine but I will pass it along to our team. If you guys do not mind letting me know what versions you are on when the function does not work that may help.

  • @michael-petitclerc that's the version that I'm on. Windows 10 amd procs. 64bit. One is an HP laptop, other is home built quad core, 16GB DDR3

  • Hi All,
    New here just signed up and noticed this thread.
    Just to confirm I am having the same problem using build
    and Windows 10 Pro, Amd processor (AMD FX 4350 Quad-Core 4.20 GHz),16GB DDR3. Also on my HP laptop.

  • This post is deleted!

  • @maker1 if you watch the video I linked, that's what I did.

  • @67exec

    Oops sorry I did'nt see the video link ☹


  • I have tried complete uninstall and reinstall, still no luck. May try an alpha or beta build to see if that helps

  • MatterHackers

    Unfortunately, we have not yet been able to replicate this issue on our end, so hunting the bug down is not exactly easy at the moment. If you did try to reinstall, you would need to wipe the folder found in your AppData folder under Local>Mattercontrol.

  • I will try that and see what I get

  • I just installed the software today and I'm having the same issue. The subtract function just causes the selected area to go kind of light or greyed out.

  • Not only is the function not working but if I make a second attempt at the subtraction the selected shapes all show as "subtract".

  • Same problem here subtract not removing part it just grays it out

  • I have tried this software on 4 computers it is very nice but every time i load it on a windows 7 pro 64 bit the subtract tool does not work but works fine on 32 bit

  • MatterHackers

    Thanks for the feedback. Polygon mesh subtraction is a very complex computational geometry problem and we are definitely working to improve it. You can always file issues in GitHub if you would like our development team to look into what is happening.


  • Hello 🙂

    First of all: MatterControl 2 is awesome.

    I want to use it in my school workshop now as cloud based services depend on the poor internet connection here- And MC has awesome features!

    Sadly on almost all machines, the subtract feature does not work as described in this thread as well. Any known fix?

    It works in the Alpha-build, as well as on two computers (with identical specs, I have not checked differences in things like .net or similar, yet)

    Windows 10 Pro 64 Bit Build 17134.706
    (A PC where it's working has .648, but one also 706)
    Hardware: Intel E8500=3.16GHz/4-6GB/160GB

    MatterControl versions: Does not work. Does not work = Works, but crashes very frequently 😉

    I tried re-installing, deleting the local appdata dir, as well as copying the working version from another computer (including appdata).

    Thank you so much for your time 🙂 ❤

  • MatterHackers

    We are working to improve it. Just to give you some tech info - subtract requires very clean geometry. The solution we use in Windows is from LIBIGL, a very sophisticated research tool, it can handle most meshes but not if they have holes. We have started working on mesh repair tools and will have the very first bits in the next release. That said, I expect it will be a few more months before you can tell we are significantly better at fixing general meshes (probably what you are having trouble with).

  • @larsbrubaker
    Thank you for your quick reply!
    I can understand that it wouldn't work with some geometry-
    But it's not working under any circumstances (e.g. even subtracting a cube from a cube) while it works perfectly fine from another computer.

    So it's a generic problem not related to the type of mesh/geometry, and rather random (given that it does not occur on a few machines with the exact same configuration).

    The old beta version works fine on all of the machines but does crash at times.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.