Temperature and material control



  • First of all, great product! Guys like you truly make the world go 'round.

    I have a brand new FFCP but hate the lack of controls in the Replicatorg software. I already copied the start and end code into the Custom G-code settings of MatterControl (minus the temp settings that show up there - don't want to override or mixup the commands issued by MatterControl.)

    Two things I can't figure out:

    1) How do I get MatterControl to issue an M109 instead of M190? OR, put the M104 extruder heat command BEFORE the M190 bed temp wait command so the extruder can heat up at the same time. I don't want it to wait for the bed to come to temp and then wait for the extruder. (I'm not looking for them to reach temp at the same time.)

    2) There are two material definitions (Material 1 and Material 2). They each have an edit button that brings up another set of General/Filament/Printer settings. The main screen already has General/Filament/Printer settings. Which set of settings gets used? Where do I tell it what material to use?

    3) Also - how do I move the part around so I control where on the bed it gets printed? I don't want to keep printing in the center and this particular part moves to a corner when I turn centering off, but I can't figure out how to manually move it to where I want.


    * EDIT - regarding #2 above, I found another thread regarding priority of settings (main settings, user, quality, material...). It's confusing because the color for user settings is awfully close to the color for Material 2. It makes it just about impossible to figure out what's going on. I still don't get how to use more than one material though. There are settings for two different "materials", but how do you actually control which extruder gets used at certain points in the print? Do the main settings end up with a mix of Material 1 and Material 2 settings if they are both selected and have settings customized? That seems weird.


  • Moderator

    It is safe to use M104 or M109 however you like in your start gcode. MatterControl will add these commands automatically if they are not present. For example, you could do..

    M104 S[temperature]
    M190 S[bed_temperature]
    M109 S[temperature]

    Here is some more information about how the start gcode is handled.


    You can move parts around through the editor. Click the Edit button below the 3D view, then you can drag the part around. This is also where you select materials for different parts of your print. Here is an article on how to do that.



  • Thanks, I understand that automatic temp codes will cancel if I have one in my custom code. The problem is I don't want to wait until the bed heats up (M190), so I want to be able to disable MatterControl from putting that in. How do I issue an M190 command in my custom g-code, but not have it do anything, so that I can cancel the automatic one? M109 (at least in my printer and many others as I understand it) is a bed heat command without waiting, whereas M190 is a bed heat command, but wait until it reaches temp.

    I tried sneaking in an M190 command after my custom M109 and M104 commands, but the order of heating and homing that ends up happening does not make sense with what the code says. It even homes slower. If I copy/paste start code that I know works into the .gcode file manually (and bring that into my Replicatorg software for my FFCP to convert it to .x3g), everything works great.

    So, I replaced all the G code at the beginning as output from MatterControl (including the M107 fan off command before the custom code) with my custom code, and manually put the M190 command back in (in the same spot that MatterControl was told to put it) and it works fine. The only difference is the M107 command at the very beginning... ???

    This is all way more difficult and convoluted than it should be. Can I just have a command that says NOT to use the automatic heat commands?



  • Yup, that M107 must be it. It's the only difference between the two codes. Even if I put it at the very end of the start code it changes everything. No bed heating, slow homing...

    So, a little clarification, at the risk of making myself look stupid. The info I had about the M190, M104, M109 codes was coming from the RepRap wiki g-code page. My memory told me it was 3D printer g-code in general. I guess there are still inconsistencies between the 3D printer manufacturers. In fact, the M107 fan off command is deprecated in RepRap; maybe that's the problem. I believe the FlashForge control is based on RepRap.

    For now I am going to have to translate all my files through Replicatorg to clean out the M107, unless there is another way to get it out of there.

    Unless, of course, I am still doing something wrong...

    Still, nice piece of software! I've tried a few so far and this is my favorite.



Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.