MatterControl 2.0 Z Offset?

  • @michael-petitclerc ok, so i'm back to a different problem. My Z axis is now going to -42 and adjusting positive after doing the auto-Leveling procedure. I have my Z offset set to -.62, per your previous comment that the z offset is configured from the top of the printer. So a -negative number should raise the nozzle for the nozzle offset. It's not doing anything as it did several weeks ago. (I'm been out of town for about a month and came back and tried to print something........The z offset is way off from what it was before I left.

  • @jeff_reynolds_beta As per his previous respose Michael and Lars are writing code for MC using a printer with the Z home switch at the Top of their machine so the negative number moves it UP towards the Z=0

  • I had a similar issue before - try the following.
    1.) Set up a new printer (I called mine "New Pulse) that makes sure you don't get messed up by some legacy settings from a prior version
    2.) Then do the setup (bed level etc) and try a print. While its printing use the control pane and adjust the Z-offset (print something big with lots of brim so you got time to do it.
    3.) once you got it set - kill the print as there is no need wasting filament (or you could have set "print first layer only" if that still exists.
    4.) note the setting in the controls for the Z-offset - write it down and reverse the sign

    1. set it to 0 by hitting the X in controls (as it gets set to 0 anyway the next time you exit the program
      6.) go to the z-probe offset and put the value in with the reversed sign that you wrote down.

    For whatever reason items that are removed from the UI are not always removed from the settings store. So the old "z-offset" that was removed becomes invisible but it is still there - happened to me. Alternatively you can export the settings and hunt for anything z-offset in the export file and set it to 0 and then import it but that gets hairy. I had to wipe all my settings 2x so far (set up a new printer or restore factory defaults). So make sure you got a written backup somewhere

  • I have a Robo3d R1+ and this new update totally killed all my settings. Nothing imported from the previous version (filament types and settings).

    Additionally like everyone else has stated the auto bed leveling feature no longer works. After probing the bed the nozzle basically sits on the glass and cannot be adjusted PERIOD! I've gone into printer/general and tried inputting Nozzle Offset to 1.6/-1.6 ..Nothing. I've gone into printer/Features/hardware and tried activating (turning on) has z prob and has Z servo.. Nothing!

    The only way that I can print using MC is to run a print with a skirt and during the skirt print go into controls/movement and raise the Z height manually to 1.6 using the Z+. It has taken me days to figure this out and I only found this out through trial and error finally getting the height right.

    My only other thought would be to program a G1 Z lift into the Start G-code right after probing the bed but in doing that you no longer have an accurate print because the bed is not perfectly leveled and I'm not sure if it will print with the same static number now in place.

    I'm running MC version stable

  • I had the same thing here is the solution

    Go into Printer
    Then features
    Expand the Leveling section
    There is an item under leveling right under Start height that say Probe -Z offset if you hover over it it says "if you do manual leveling its the thickness of the paper. Set that to 0 as the default is 1.6 - I guess really thick paper. Then your offsets will work more predictable

    Also remember the offset you set in controls will go away after you go out of the program. The whole Z-offset mess was a reason I started to look into other slicers and yes its a pain but at least more predictable and I get some other features. So I slice in slic3r and then run it through MC for bed leveling at least until they improve MC and make it more usable (including volumetric printing) or I figure out how to bed level manually in slic3r as I am not replacing the BLTouch for a 4th time

  • I tried that probe Z offset in leveling as a Z offset and that does not work what it does is include it into the offsets from bed leveling and then apply it in runtime. You could probably go and edit the 3x3 mesh results table and +/- the 1.6 depending on how the handle that currently there . But I think its easier to set it to 0 and relevel the bed.

  • @mpirringer your solution of adding a new printer solved my problem.

  • @larsbrubaker The note in MatterControl says that this setting is ONLY useful for multiple nozzle printers.

  • Well it works sometimes

  • Hi all,
    12 month hiatus on printer use, and I'm experiencing the same pain as I'm reading through here.
    I think most of my questions are answered, but I can't find where the auto-level enable is? Can anyone help? Thanks!

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.