Can't export X3G - MatterControl 2.0

  • I am having the same issue. I have a CTC Bizer dual extruder (Makerbot Replicator clone) and while I can run the printer just fine with the current version of MatterControl by connecting a USB cable between my laptop and the printer, I can't get the software to export viable .x3g program files to an SD card so I can run the printer that way - all exports seem to come out in "gcode" format.

  • It looks like the bug still exists in the current release as well as in the alpha, at least for WIN10. Although .x3g export is selected there is always a ._gcode file generated.

  • This issue still exsists - very frustrating. Any workarounds avaliable?

  • I've had this issue for a while now and its driven me crazy as the USB connection to my Flashforge Creator Pro sometimes seems to freeze mid print - so the SD Card *.x3g route seems to be the most reliable way for me. But I just couldn't seem to get the program too produce the *.x3g files.


    Not sure if this will work for others (I would be interested to know) but here goes... So I found that Mattercontrol 2.0 only seems to fail to export the *.x3g IF it comes up with the "Possible Unsupported Parts Detected" error in the export file window. So I found if I then made sure to generate supports, it started to export the *.x3g files just fine.

    But that was annoying as there were a few times when I DIDN'T want to print with supports. So I found that if I opened the "Generate Support" tab at the top of the main window (next to the "Arrange All Parts" button) and set the "Overhang Angle" to 0, the error went away and I could export unsupported parts.

    Like I say, no idea if this will help anyone else, but thought I would share in case it does!

  • MatterHackers

    I will look into this over the weekend. Thanks for bring it back up.

  • MatterHackers

    Thanks for describing this error in more detail. The tip about support really helped. This is now fixed in the Alpha version. Please let us know if this is working for you.

    Thanks again.

  • @larsbrubaker Fantastic! Thanks so much for taking a look at that and I'm glad the support trick worked! I'll download the alpha now to try it and report back. Cheers!

  • @larsbrubaker So I just downloaded the alpha on my Windows machine and it works perfectly! Problem fixed! Thanks!

    I also tried it on my two mac machines (one very stable hackintosh and one Macbook Pro 2015) and found that the problem is still there on those. I don't have linux installed at the moment so I can't test it on that.

    Would it be possible for you to take a look at the Mac OS version as well?

    Thanks in advance!

  • MatterHackers

    The mac build has not been updated yet. Will do it soon. Apple is always a moving target and it is hard to get it released at the same time as Windows.

  • @larsbrubaker ahhh that makes sense. Good to know! I'll stick to the windows version then. Thanks again for all your hard work.

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.