exporting stl

  • @larsbrubaker Thanks, but still not working for me either.. made no difference at all 😞

    I had to fire up an old PC that had an old version installed yesterday, then tried saving the work I had done and could not export as an .MCX file and tried to open it in the old version. but it didn't work and I had nothing ...
    So I had to start from scratch in the OLD version , on the old PC, and do the whole object again .. so I could export it as an STL.
    Keep working on it please 🙂

  • @larsbrubaker Re-installing the old version is not working either .. I will do another test, after uninstalling the current one

    EDIT _ Ok uninstalling the current one & installing the old one didn't work..
    All my "workspaces" were still there ,. so the error is prob NOT in the exe, but in the user data somehow,, I am busy with work now, but I will find & NUKE all my user data when I can and see if the OLD version allows exports again.. I am in a rush right now, so will try a bit later

  • @larsbrubaker Hi again.
    so.. The old version you posted does not export, the hotfix does not export...

    1. I uninstalled & removed all the user data and installed the OLD one you posted, and no export.
    2. updated that and no export.
    3. found the really old (2019) install file on my old PC ( which is now running a WORKING ) but the install I found was - and installed it and export WORKS...
    4. updated it using teh "update" in the program and is STOPPED working.

    Note I deleted user data between each full install - so it is NOT the user data as I though. The last working version i know of then is which I cannot re-install as the OLD one you supplied ( seems to have the same problem as the current one, so I think you need to go back a few more versions to find a working one (IMHO)
    This was all done in a rush 🙂

  • I reinstalled Version and my export works now!😀

  • MatterHackers

    I fear that I do not know what steps you are doing to reproduce this error. It may be that it is very easy to fix, if I knew exactly what you are doing.

    Could you download ScreenToGif and record the actions that you take to have the error.

    If you have problems uploading the gif, you can easily put it on GitHub.

    Thanks in advance.

    BTW: You can find download links to old versions in the Release Notes.

  • @larsbrubaker there is no need to do a gif, the visual is this..
    Right click on the object - the Right click menu appears
    left click on the "export" and the menu just disappears.. and nothing happens.

    It is like the "export" menu that SHOULD appear simply does not exist in the code. - all the other menus pop up from the right click menu fine..
    If you click on the "drop arrow" on the save button and then "export" then again, nothing . nada... It just disappears like the next menu doesn't exist .
    I don't know what the common thing is that makes this not work, but I have done a CLEAN install on this PC and it doesn't fix it - If it was linux I would say it was likely a permission issue
    with the menu... but it isn't 🙂

    (EDIT) I can't see links to old versions on the page you said
    0_1615916044152_7ade9a44-f1d4-4c42-b988-498d896f3469-image.png (and the links on that page don't work LOL)
    (edit) I found them here http://wiki.mattercontrol.com/Release_Notes

  • MatterHackers

    Oops, here is the right link.

    I am now able to reproduce your error I will have another hot fix up in a few hours.
    Thanks for the details, that was very helpful.

  • @larsbrubaker Awesome! I like the new color settings i can now use yellow when its fixed! And when you have the time could you guys fix the black/dark color on the mirrored objects so it can be the same Bright color as other parts? Thanks guys!

  • @larsbrubaker Wonderful 😉
    Thanks for being on the case too BTW!!!

  • yup no problem man!I was just trying to help get this fix fast. So i can get back to work on my R/C truck! lol0_1615928348524_Capture 7776.PNG

  • MatterHackers

    There is now a new build that fixes the issue as we understand it. Please let us know if this is still occurring and we will continue to investigate. And thanks to all of you for helping track this down and being responsive.

    The issue with Mirror is fixed as well 🙂

  • MatterHackers

    @blades808 Did you model that in MatterControl? Very impressive either way, but it would be amazing if it were in MC.

    Thanks for sharing.

  • @larsbrubaker yes i did it in the MC but i downloaded the engine block! I did the headers on the engine to.And I'm using the free MC!

  • @larsbrubaker sorry I could "play" earlier 😉
    YAY!!! At a first look all is well again! Thank you for your hard work!!

  • @blades808 Just WOW!!!
    That is amazing work.. I wish I had the patience to do that 🙂

  • MatterHackers

    @whonose thanks for the feedback. Glad we got it fixed. That is now part of our testing suite.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.