CTC A8 clone issues

  • I have a CTC A8 clone printer and was looking to upgrade firmware to enable auto bed levelling but Cura refused to see the printer connected via USB (using Windows 10 Pro btw). A few searches led me to a CH340 USB-Serial driver, repetierhost and Mattercontrol.

    Firstly if I allow the RAMPS driver supplied with mattercontrol to install rather than the CH340 then the software can't connect to the printer.

    Using the CH340, matter control connects to the printer and i can control movement (I've not tried a print over USB yet). I thought I'd try the software bed levelling before looking further at a sensor and updating firmware, but I'm having issues. The wizard starts and moves the head to the 1st point, but clicking Z- moves the z-axis to a completely random position. I believe the last one was +637, rather than stepping down 1mm. clicking Z+ to stop has no effect (although the number on screen changes, it jumps randomly from what i can tell, +637 to -1234 to -765 to +423) I'll try to get some screengrabs when I'm the PC the printer is connected to. The only way to stop the Z axis movement is to turn off the printer of close mattercontrol.

    Any suggestions?

  • I think I've solved it. The board had repetier on it, switching to Marlin firmware seems to have fixed the leveling setup.

    Unfortunately I'm now having issues with the print head being too low to lay the 1st layer after levelling.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.