Help, MatterControl1.7.5 is dropping the Z Axis before the first layer is printed



  • Hi,


    I just downloaded and installed MatterControl (1.7.5) for my CTC Makerbot ReplicatorDual(Sailfish7.5). When I print the test cube it starts fine, gives me a great first layer, but when it starts the next layer the z axis drops almost a full 5mm. When I print the same cube with Makerbot, all is fine. When I print the ring, I have a simular issue, only now it drops the z half way through the first layer. Help!



  • This seems like a bug in the software. Please someone reply?


  • Moderator

    Please be patient and give us at least one business day to answer questions.

    How do you know it is trying to drop 5mm? It can't actually move down that far since the bed is in the way.

    We're going to need a print log to investigate this further. Please upload it using a service like Pastebin.



  • Ok,


    I'll get you the print log. BTW the Z Axis stepper is actually releasing and letting the bed go down. I tryed it again tonite after reseting everything.


  • Moderator

    Ok. I'd just like to clarify what you are describing. Things can get a little confusing on these printers since the bed moves up and down, not the nozzle. You are saying that the bed moves down ~5mm (i.e. the Z axis moves in the positive direction). You are not saying that the bed moves up (i.e. the Z axis moves in the negative direction). Correct?



  • Actually it is releasing the stepper that holds the bed so the bed falls all the way down to the floor of the printer.


  • Moderator

    Henry,

    I had a look at the print log you sent us over email. I don't see anything that would indicate why the Z motor would be released. It does not contain any M84 commands (the command for disabling stepper motors). I will ask our X3G expert if there is anything in the X3G processor which might cause this, but I doubt it.

    I did notice that you have software print leveling enabled, which creates a lot of Z axis moves. Have you tried printing with the software leveling disabled?



  • Yes I thought of the print leveling last night and turned it off. It still did the same thing with the bed thogh.


  • Moderator

    I consulted with the lead developer of the X3G module. We are absolutely sure that MatterControl is not sending any commands to release the motors, so I'm not sure what is going on here. What happens when you move the Z axis manually from the controls page? Does it move the correct distance?



  • Yes it does. Not sure if this matters but I have upgraded the original control board in my CTC to a GEETEK Makerbot clone board, because my original burned out. I have had no issue with the Makerbot desktop and Makerbot Printer software. I'm also running Sailfish 7.5 Replicator Dual.



  • OK,


    Something odd has occurred. I had been trying to print with the computer plugged into the USB and of course ever time the Z axis stepper would loose power and drop the bed while still continuing to print in the air. I decided to us an SD card instead to print the Benchy Boat. Well it printed beautifully, much better then the Makerbot desktop software. But why does it work from an SD card and not if the PC is plugged into the USB and running the print?



    BTW with Makerbot Desktop and printer software I get stair stepping the bow of the ship, but with your slicer bow is smooth. I tried to insert the photos here but it will not work. I will instead email them to you.


  • Moderator

    Well I'm glad you are getting such good results with MatterControl. In the future, you can upload images using a service like Imgur, and then post the link here.

    Can you post your On Connect G-Code? At one point there was a bug where different settings would be applied when exporting an X3G file than when printing over USB, but this should have been fixed.



  • M92 X94.6 Y92.02 Z397 E91.85 ;sets steps per mm for x3g driver
    M206 X152 Y75 Z0 ;sets home offset (opposite values of bed size)


  • Moderator

    Your M92 values are strange. Did you change them? They are still pretty close to the defaults (Z is 397 vs 400) so I don't think that is causing the problem.

    Really not sure what is going on here.



  • Yes I calibrated them.using a calibration cube.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.