MatterControl crashes when opening files (Debian Buster 10.5)

  • Hi. I would appreciate some help please. I have downloaded mattercontrol (Version to try on my desktop machine before biting the bullet and purchasing a 3D printer. I can design files but when opening an STL or mcx files, mattercontrol loads and almost immediately crashes.

    mono version: (tried 6.10 as well)
    kernel: (from buster-backports) also tried 4.19.0-10-amd64 and 4.19.0-09-amd64
    GPU: [AMD/ATI] RS780L [Radeon 3000] (yes, an oldie but serves me well otherwise)

    Perhaps it is the graphics card? But does not explain how I can design though...

    Log attached...

    [0_1596794248728_log.txt](Uploading 100%)

  • Hmm... Does not look as if the log was uploaded... Perhaps because this was my first post? Too much text on the logs though to enter it here.

  • Seems to have been able to resolve this. Looks like the monocomplete metapackage from xamarin does not actually install all / or the correct version of some of the files. Once I installed monodevelop as well, in preparation to compile, it works.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.