Layer View with CuraEngine not starting with layer 1

  • MC build on Mac, Robo3D 1+.

    When printing, I usually use Layer View > 3D > Display > Sync to Print. The initial display looks as if about 12 layers had already been printed. Then when the printer reaches layer 13 the display starts to climb upward. Even the skirt is shown as multiple layers, which it clearly is not IRL.

    I *think* that in the main printing view this only occurs when CuraEngine is selected, but I'm printing now so I can't be sure. From the print queue > View, this clearly only happens with CuraEngine. Here's the same model with Slic3r selected, then viewed from the print queue, and you can see it starts at layer 1:

  • I haven't seen this, so I'm not sure what is causing it.

    It could be a bug in a version that is out of date. Does the same issue occur if you run the stable vanilla Mac version available from ?

  • That is the version I'm running. I think this may have started about one version back. I've only been using MatterControl since January, and I know it was not doing this back then.

    After some more testing, it appears to be intermittent. If Cura is the current option when I start up MC and add a model, this occurs. If I switch back and forth between Cura and Slic3r and MatterSlicer, it won't always occur, but will sometimes. But only with CuraEngine.

  • It's an interesting bug, and ideally we'd be able to fix it. I'd like to be able to tell you we will, but the reality is that other projects take priority and our support for CuraEngine or CuraEngine-related features/bugs is mostly nonexistent going forward. Future versions of MatterControl will not have other engines, so we're basically offering the old versions with third-party slicers as-is, bugs and all.

    In any case, thanks for showing this to us. It will be marked as a known bug.

  • In other words I should get used to MatterSlice 'cuz the others are going away...

  • Is it just me, or is MatterSlice *really* slow compared to the others?

  • Not sure what kind of answer you're looking for here. Seems like you're bordering on violating rule 3:

    Do you have a constructive question to further the thread?

  • @ryan.lutz said:

    Not sure what kind of answer you're looking for here. Seems like you're bordering on violating rule 3:
    Do you have a constructive question to further the thread?

    I am new to Matter Control. The 3d Printing group on Facebook recommended it. So far I love it, it is the perfect bridge between all of the slicers and what-not, so I can really get what I want without a lot of mucking around. However I ran into this same problem, only when using Cura Engine as the Slicer (Which I didn't want to use, but this PARTICULAR part and the way the supports work creating a round hole vertically with overhangs required Cura Engine for a perfectly round hole) again, I am somewhat new to this, using CuraEngine as the slicer was the only work around I could find in my particular case involving supports. So, onto the question, I noticed the last response here was 5 months ago and I can't find any further information on how to solve it, here or anywhere else. I am kind of afraid to post this after reading comments about rule violations etc. I am still trying to find a fix myself in the meantime, but really, I dont know how I can without having the actual source code and run in debug to see what Open GL is really doing. I am using version 1.7.5 and am stumped. I still want to take a second and just state for the record, Matter Control is the BEST software I have come across, even after looking at pay versions of others offerings. Thanks in advance for even the smallest amount of help, even a crumb of insight would be appreciated and I am sure helpful.

  • P.S. My head must be inserted somewhere dark..... I am using MC 1.7.5 (Latest stable build to date) Windows 10 Pro, Hictop I3 clone as well as Fudream IM-3040 Plus (hybrid CR-10s dual Z and Tevo Tornado) tried while connected via USB live wire as well as not connected and exporting Gcode to SDCard. Sorry bout that.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.