Startup Failure: MatterControl (3D Printing Software) 'The type initializer threw an exception'

  • I'm tearing out my own hair trying to figure this out, just wondered if any of you have had this problem? I use MatterControl to do my 3D Printing and I particularly like using MatterControl. Recently, I was printing Giants for my tabletop gaming and these files are big so they definitely slowed the software down a tad, though not catastrophically. I think it was as I was slicing or about to print something, I cancelled it too quickly and it crashed. Standard stuff, relaunched and get this error message:

    Startup Failure:

    The type initializer for 'MatterHackers.MatterControl.SlicerConfiguration.ProfileManager' threw an exception.

    A quick google revealed this is something to do with the JIT Debugger, which is where my knowledge for this stuff falls short. Here are some basic troubleshooting things I've done before posting

    • Restarted

    • Done a clean boot

    • Reinstalled MatterControl

    • Tried an older version of MatterControl (the software never launched)

    • Tried to disable JIT Debugger through deleting it in regedit, also through Visual Studio and regular settings, still get the same error.

    I can also copy and paste the details it gives when it comes up with the error if that's any help.

    I would love to know if there's a potential fix at all and how would I go about doing that?

    Thank you!

  • Had the same problem. Here's my guesses as to why and how I fixed it (in Windows).

    I've got a really old R1, so I've been using old software. I tried updating to the latest MC, and got the same error. I'm guessing the latest MC has an issue in creating the printer profile if there isn't one on your machine already.

    I downloaded the 1.75 version, and it opened fine. I went through the "create an online account" and picked out the printer I have. Then once it gave me the basic desktop, I clicked on "upgrade available" at the top and walked through the steps to install the newest version.

    Now the new version opens fine.

  • This post is deleted!

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.