[solved] Z offset not working ?



  • Hi to you all ! I'm using an inductive sensor which works well for me on a chinese prusa i3 clone and MatterControl 1.7 in Linux. Now recently I've changed my nozzle and there's a difference in height, approximately 2mm shorter. Then now when I start a print, my nozzle won't even touch the bed. So I though I should use the Z offset setting to compensate, lowering the nozzle (I've put -2 in the Z offset setting). But it is not working. It seems whatever I put in the Z offset setting seems to have no effect, so I think I have another setting that is interfering. Since I also use custom start gcode, I'm wondering if one of thoses lines below is preventing me to get the Z offset working (G92 line maybe ?) :

    G21 ; set units in mm
    G28 ; home all axes
    G29 ; bed calibration
    G90 ; set absolute coordinates
    G92 E0 ; reset extrusion distance
    G1 E7 ; extrude anchor
    M106 S255 ; print fan on

    Am I correct ? Or should I try something else entirely ? What is the best way to compensate for height change in MatterControl when using an inductive sensor ?
    Thank you for your answers and have a nice day !



  • I think I've figured it out, at least why the Z offset is not working : I think the printer is not accepting negative values for the Z axis as of now. But I have no idea how to change this behavior or if there is another way to solve this without changing my inductive sensor position every time (which is exhausting, and innacurate, at best). Any thoughts please ?



  • I've found a working solution for my Z height issue, even if I'm not too sure if it's a proper way to solve this : I realize I could tweak the Z offset manually from the printer menu, so as soon as I remember my z offset setting in Marlin (rc bugfix) was -0.5, I've changed it to -1 and I can now use the Z offset setting in Mattercontrol for slight adjustements (which is quite convenient when changing filament, with different needs). Solved. For now.


  • Moderator

    Correct. Most printers do not allow you to travel to negative Z values. However, this can be disabled in the firmware configuration. In Marlin, the option is called software endstops. With that turned off, you can use MatterControl's Z Offset setting without limitations.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.