Stuttering and leaving blobs during printing.



  • I have the following problems:

    Stuttering and leaving blobs during printing.

    iMac Core i7 OSX, Delta with Marlin firmware (also tried latest 1.1 RC7 marling firmware). Also v1.5 had this problem. I hoped that with 1.6 the problem would be fixed. I want to use mattercontrol because of it's features but printing over USB is terrible.

    Always stopping and giving blobs in the print.

    The cause: Mattercontrol is (like other apps) reading the temps of the bed and nozzle during printing. Every time the temps are read the printer stops for 0.5 seconds leaving a blob on my print.

    Exporting from Mattercontrol and printing the gcode using pronterface or any other 3d printing app (which also read the temps) results in a perfect print. Somehow the serial communication from Mattercontrol on a Mac is slow (MONO layer).

    I dont like Cura but it does the job without blobs.

    THIS IS THE ONLY 3D PRINTING APPLICATION WITH THIS PROBLEM!, i tried all others (cura, pronterface, repetier etc.) without this problem

    So please Mattercontrol team fix this problem.



  • Thanks for your feedback. We're aware of scattered problems with Mac builds of MatterControl, and while they are not ideal they seem to affect only a very small percentage of users.

    Please also keep in mind that MatterControl is free and open source. With unlimited resources we would have a much easier time fixing every bug found, but our team is small and unfortunately our resources are limited. When we take on a new feature or area of development we do so with the hope that it will benefit the 3D printing community at large, and weigh the pros and cons against those of other possibilities.

    In this case development for fixing this issue is pretty low priority. If you are interested in sponsoring some development we might be more willing; in that case please contact us via email at support@matterhackers.com.

    Thanks again!



  • Look at the MatterControl terminal output to see, if MatterControl is sending a continues stream of commands to the printer, or pauses in between batches of commands.

    I had an issue once where MatterControl was pausing in between commands because it was dealing with errors writing to its database. The pauses went away after the database issue was resolved.



  • I already did that and the stuttering (pauses) occurs when the temps of the bed and nozzle are read in between the print stream.

    The temps are read just after each other and then the printing stream continues.

    If the temps are read alternated, e.g. read nozzle temp, print stream (for number of seconds) , read bed temp, print stream print stream (for number of seconds) , read nozzle temp etc.,

    The temp reading will influent the print stream less in that case.

    The printer itself controls the temperatures so matter control does not need to read it frequently.


    On the other hand other apps do not have this issue and are also reading the temps.

    But I like Mattercontrol very much and want to use it without the need of other applications



  • New version: 1.6.2.8242

    Still the same problem.


    Why reading the temps so often???????????

    This is causing the problem. The printer controls the temperatures itself so why reading it every 0.5-1.0 seconds?

    And why reading nozzle temp and bed tem at the same time? Its a simple change to alternate this.

    And the single threaded moe model..... makes things so slow on a Mac.

    Its a pity and there are many Mac users but MC needs some tuning.




Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.