G-code errors

  • I am getting some errors occurring during the start of a print. I have an Electron Prusa i3 with an MKS 1.2 board. I am running the original version of Marlin that came with the board, maybe 1.0

    At the start of a print the message on the screen changes to Sleeping... This is during the heating phase.

    When I watch the console I see two points where I get an error saying that the line number did not equal line number-1 (sic) One of these is during a G28 Z0 command and one during the G29 auto level. I can see in the code that two lines N# are on the screen with the same number and same command. I took a look at the G-code export for a model and everything looks fine, so I don't know the cause of the duplicated line numbers.

    Another interesting thing is that I can get the same error if I open the console and send "M117 Printing.." the text never appears on the display (It did appear when I used Cura) I tried some other text and found that "M117 Working" also does not work. Many things do work, however, hello, Busy, Idle... etc.

    I can get decent prints now that I have ironed out the settings, this start G-code is kind of a minor annoyance.

  • This is normal. MatterControl automatically resends a line if it does not get the ok response back from the printer after a certain amount of time. The G28 and G29 commands take an exceptionally long time to complete and the printer does not send the ok back until they are finished. The error you are seeing is the printer complaining that it got the same line twice, however this has no ill effect on printing. Everything proceeds normally after that.

    Not sure what the issue is related to M117. Could be something to do with your firmware. I just tested it on our TAZ and it takes any arbitrary string with no problem.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.