FlashForge/Ubuntu Issues

  • Hi,

    I just found MatterControl, and am very interested in testing it out. My printer is a FlashForge Creator Pro (PowerSpec 3D Pro clone; everything about it works identically, over a year of use). I run Ubuntu linux on my computer.

    I've been using Slic3r, which does a decent job, but I prefer to kick off my prints from a control panel rather than print from the SD card, and think MatterControl could be the control tool of choice for me. (I know, SD card printing is preferred by many, but my linux system is very stable, and I really prefer that workflow). (long story short; makerware and replicatorG have both stopped working on newer releases of Ubuntu)

    I installed the newest MatterControl for linux, and picked the FlashForge Creator Pro Dual printer and connected. All was good, it connected, and when I tried to print, it did send commands to the printer, which did try to move in response to MatterControl instructions.

    The first problem is that the start and stop gcode don't work correctly. I can see that the 3 lines of custom start gcode don't do anything like what is required to get the Flashforge to heat up and print.

    I found the /usr/lib/MatterControl/StaticData/PrinterSettings/FlashForge/Creator Pro Dual/config.ini file, which has a start_gcode line and an end gcode line that have the same control codes that are listed in the settings window.

    I have working start/end gcode for slic3r, and figured I would set that into the config.ini file and try that. Unfortunately, when I next started MatterControl, the original gcode still shows up in the custom gcode pane. Am I making my modifications in the right place?

    Additionally, I would like to use the slic3r slicer, but in the linux version of 1.5.0 build 6404, MatterSlice is the only active option in the options pane.

    Can anyone offer any hints here? I see the FlashForge Creator Pro is listed as a supported printer, so is my issue related to running under linux? If so, hopefully I can work through this and share what works in that environment to help others in the future.

    Thanks for any insights you can offer.



  • Couple of things...

    1. What exactly is wrong with the default start gcode and what are you trying to change it to? We've done extensive testing with our own Flashforge and it works fine.
    2. Why are you trying to change the config file instead of editing the start gcode from within MatterControl itself? The settings in /usr/lib/MatterControl/StaticData/PrinterSettings/ are the default settings loaded when you add a new printer. Your own settings are stored in an SQLite database in ~/.local/share/MatterControl/ (in 1.6 these will be moved to .json files)
    3. Slic3r and Cura engines are disabled for dual extrusion printers, since MatterControl currently does not support dual extrusion using those engines. I realize its a little confusing to have them completely hidden in the menu. If you want to try Slic3r anyways, switch your extruder count to 1.

  • Thank you for your comprehensive information.

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.