Linux Mint no Usb serial connection

  • MatterControl v 1.5 on Linux Mint.

    I cannot seem to get the printer connected. the device is /dev/ttyACM0 and arduino connects just fine.

    I also just installed repetier-host and it worked first time.

    I am in dialing group.

    Mono version 3.12.1

    Linux mint 17.3.

    Printer is rostock max v2

    Any ideas?

  • I assume you probably checked this, but do you have the right baud rate selected?

    If so, does MatterControl give you any messages? Does anything come up in the gcode terminal when you try to connect?

  • Sorry late replay was on binus travel.

    Yes the baud is 250000. The terminal only prints "Lost connection to printer"

    Thats it. is there a debug mode or some other log file i can check?

  • Are you on a 32 bit machine by chance? I think I know whats going on here. 250000 baud was the important clue.

    On Linux, MatterControl uses a small helper library for setting baud rates above 115200. This is because Mono does not natively support baud rates that it considers nonstandard. This library consists of two files, libSetSerial (which is used on 64 bit machines), and (which is used on 32 bit machines). I just checked the package we are shipping and apparently for 1.5.0 we forgot to include If you have a 32 bit system, this explains why you can't use the higher baud.

    I am including the file here. Simply put it in /usr/lib/MatterControl. A bug has also been filed, so the next update should not have this issue.

  • um...why yes(686) thanks for asking. That fixed it!!

    Thanks a lot for the help. Good catch.


  • This post is deleted!

  • I also have problems with connection. I connect the printer in USB port, and when I click to connect, it shows "Attempting to connect...", and does nothing.

    I'm using Linux Mint 18.1, 32bits.

    MatterControl 1.6.1

    Printer model: 3D Cloner DH

    Mono 4.4

  • @mluizvitor, did you try adding the serial helper library as I described earlier?

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.