Mattercontrol wont home

  • I can seem to get matter control to center the print head
    it begins to print bottom left corner off of the bed
    I had posted this already and thought I was finding a solution via the thread however the thread is gone and i was locked out for a day or so .. not sure why and no one seems to know
    printer is Airwolf Demo XL 3d printer
    Firmware is Mendel
    I was asked for pictures of the settings tabs and am re posting them right now here ..

    anyone able to help .. it was an admin I was conversing with as well as another member

    I have played with the GL Code and from what I understand of it that should have worked but it didnt

    thanks in advance

  • @tasiqbd9 the link refers to best smart phone in rajshahi .. really won't be clicking on that.

  • MatterHackers

    I'm not sure what you're trying to show or trying to do, but for starters, that's bad start gcode.

    G28 is the home command. Sending those coordinates after G28 is invalid syntax and either won't work or just won't do anything.

    Are you just wanting your print to be centered on the bed when you print? If so, you just need to click the Arrange All Parts button on the toolbar

    If you're just wanting to move the print head to the center of the bed, home the machine first using G28, then send this command to move the print head to the center

    G1 X147 Y115 Z10 F1800

  • @cope413 thanks for that. Unfortunately that is the code in the program I really have not altered it as of yet as I am not fully comfortable with gcode I'm learning .
    The printer won't center.
    Homing it brings it to the bottom left side off the pad.
    Whe I go to print it does the same thing. Goes bottom left side off the heat pad.
    That's the part I'm trying to fix. I want it to print on the pad
    Any help is appreciated. I'll look at your options and try those first

  • MatterHackers

    That's where the homing position is - it's all the way to the left, all the way to the back, and down to the bed.

    I don't know where that code came from. The default gcode in Mattercontrol for the Airwolf XL is this


    Can you export the gcode and attach it?

  • @cope413
    I put in the code and there is no longer any home button but the head does not immediately move to the far left corner .. when I begin to printer however it immediately goes to the left corn off the heat bed and looks like it is going to start but just drips a bit of filament ...
    as I said I am not over versed in the gcode so this for me is trial and error ..

  • MatterHackers

    I really have no idea what you are describing. If you can't attach your gcode, I don't know if I can help you.

  • I put the code in as you screen shotted there.
    I no longer have a home button to bring it to home.

    What I am describing is this ..

    I click print.
    The printer regardless of where the print head is, it will immediately go to the bottom left corner off of the heat pad and begin to print on the metal surface off of the heat pad.

    I do understand it is hard to help me when I know very little about gcode. The code you have above in the screen shot I have put it.
    I do not understand what you mean by attaching the gcode. If by attaching you mean the start and end gcode as screen shot above I have done that.
    I am sorry I do nor fully understand this but that is why I am here looking for help ...
    thanks and I hope I was clearer as after re reading the last reply I gave it sounded a bit cryptic

  • MatterHackers

    That's not the gcode - that's just the settings. Export the file you're trying to print as gcode.



  • Ok I have that now .. still having the same issue
    when it print the nozzle goes off bed bottom left hand corner.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.