Printrbot Simple Metal Auto Leveling.

  • Hi,

    I have started using Matter Control and so far I am loving the software's flexibility however I am having big issues with the Auto Leveling. My Printrbot Simple Metal works great with Cura however I have found it to be pretty unstable hence me looking at Matter Control. Anyway, the problem I am having is if I click on the Hardware Auto Leveling within settings, I find that matter control does not set the height correctly for my hot end and the nozzle starts spewing filament out about a centimeter above the bed. Unfortunately I can not manually adjust the hot end on the Printrbot, the height is set. The only way for me to get around this is by using the Z-Offset feature within Matter Controls settings and this only works once the Hardware Auto Leveling feature is turned off. So I switch the Hardware Auto Leveling off and calibrate Matter Control to level the bed but its not calibrating correctly.

    I have tried the 3-point, 7-point and 13-point and the results are always the same, quite clearly Matter Control is out of calibration with relation to the bed and my prints start to lift on the one side, something that does not happen with Cura at all. Irrespective of how I calibrate, I can see the bed is leaning closer to the hot end nozzle on the one side. I've tried to calibrate this many times and the result is always exactly the same.

    Any suggestions? This is great software but without me being able to level the be correctly I cant really use it.

  • Did you have any leveling problems while using Cura? In Cura, did you have a Z offset set? What did your start gcode look like?

    MatterControl's software leveling is probably not going to work on the Printrbot, since it will conflict with the Printrbot's own hardware leveling. The wiki has more information on the different types of leveling. You say you switched off the hardware auto leveling. How did you do this? The "Has Hardware Leveling" check box in Settings > Printer > Features does not actually turn it off.

  • hmmmm, I had a suspicion that may be the problem and yes there is a z-axis offset that was set using the M212 command and there is a G29 code at the start of my gcode. I just glanced over the link you gave but it looks like it may. I'll take a look at it tonight 🙂 thanks for the info

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.