Pretty annoying - Export window won't close

  • Exporting my GCode and once you choose where you want the export to go, it exports fine but the File Location window won't close. It just stays up.You cannot X it out, cancel... It is stuck there. You can drag it away and continue to work on MatterControl...but kind of annoying.... You have to close and re open Matter Control to get rid of it.

    This is on an M1 MacBook

  • MatterHackers

    @damianoffthegrid Obviously not expected behavior, so we'll take a look at that. One thing you can try instead of closing/opening MC is to change the theme (bottom right corner - paint palette icon). This forces a reset of the UI and may fix the state it gets in.

  • @cope413 This problem is still there. Pretty annoying. Every export the popup is stuck open and I have to minimize the MatterControl display so that I can hide the popup in the background or close and re open the software. If you export will now have a second file browser popup open...then a third...

    Changing themes does not make it go away.

    Shown here

    image url

    This is after a successful export....the window just sits there "dead"....might as well be a graphic on the display as nothing on it will click or function other than dragging it out of the way.

  • MatterHackers

    We are going to a have a new build in a week or so. I'll try and reproduce this on a OS 12.3 mac mini and a few other test machines we have (iMac and a couple mac books). I tried when you first posted it and couldn't get this to happen, but I'll dig deep and see if there is a way to make it occur on a test machine so we can fix it.

    Thanks for the update.

  • MatterHackers

    I tried this on all the macs I have access to and cannot reproduce your issue. I will keep trying but my export works as expected and the system file dialog closes correctly. If there is any more information you can provide or maybe make a video (if that is easy) of it happening...

    I wish I knew what else to look at. Like I said, I'll keep trying.

  • @larsbrubaker are those M1 Apple silicone Mac’s you’ve tried…?

  • MatterHackers

    Yes. I have 3 M1 macs, one mac mini and 2 mac books. They all seem to be doing the right thing. Don't yet know what could be causing this.

  • @larsbrubaker Will start figuring out the pattern and sending the video process to recreate it. Won't be hard as it literally happens more than not. I will say, I noticed when I fresh open MatterControl, I will get one or two exports, then after that it is stuck open. So there is a pattern there I just need to pin point it.

    Maybe after a print job, then an export...canceling a print or export...but it is definitely reproducible on my system.

    One thing I do want to verify... as I have not checked, is if this is only happening with that problem child Pulse XE we are discussing in the other thread loaded up on the screen or if it happens with the other Pulse loaded up on the screen as well...

    I have been concentrating more on this Pulse XE issue I'm having but will pattern this bug as well.

    I literally just got a new MAC Studio in today, that I am currently loading up as my dedicated printer computer... so will see how this all operates on that new M1 Max setup as well.

  • MatterHackers

    Thanks for hanging in there on this one.

    I found some documentation on this issue and was able to reproduce and fix it. It will be fixed in the next update and is currently available in the 'Alpha' channel if you check for updates.

  • MatterHackers

    @DamianOfftheGrid it would be great if you can verify that this fixes the issue for you. I don't know if you saw my last post as I added your @ after creating it and that may not have sent you a notice.

    Hope this fixes it for you.

  • @larsbrubaker Will give it a shot....still trying to get this second Pulse XE to act like the original... will export some prints out to the VORON Trident and test it out

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.