What to do if your ROBO keeps trying to print up in the air


  • Moderator

    This is the number one issue we see with the Robos. The printer will not do its calibration sequence right, then start trying to print in the air, a few centimeters off of the bed. Fortunately, this is a very easy fix as long as you understand how the Robo's auto calibration works.

    Whats happening is the Z endstop switched are getting falsely triggered for some reason, so the printer thinks it has gone down and touched the bed when it has actually not. The Z endstop switches are the two switches on either side, on the threaded rods. They have wires going to them. The X axis rests on top of them. When the printer moves down and the nozzle touches the bed, the X axis get lifted up off of the switches and they are triggered.

    If the switch get dislodged somehow, the X axis will not push down on it. Here is a video that demonstrates this and shows how to fix it.

    It still doesn't work

    If you've made sure that the switches are seated correctly but it still tries to print in the air, you are probably looking at an electrical issue. The switches form a normally closed (NC) circuit. If there is any disconnection or break in the wires, the printer will think the switches are getting triggered.

    To see if the switches are triggering correctly, send the M119 command through the G-Code terminal. This will report the status of the endstops. z_min should be open when the X axis is resting on the endstops and TRIGGERED when it is lifted up.

    Make sure that both wires are plugged in to each switch. They can easily get pulled off if the switch gets dislodged and spins around the rod. If that is not it, then follow the wires all the way back to the controller board under the printer. If there are no obvious problems, verify that the switches are working correctly using a multimeter.

    I tried to use software leveling (with the paper) and now its all screwed up

    Software Print Leveling will not work with the Robo. The Robo has hardware leveling which allows it to probe the height of the bed before each print. Other printers don't have this feature, so for them MatterControl has the option to use software leveling. This is where you measure the height of 3 points on the bed using the piece of paper. If you try to use both types of leveling at the same time, they will conflict with each other and cause all sorts of problems. Because of this, the option for software print leveling is deliberately hidden.

    To ensure that software leveling is turned off, do the following:

    1. Go to Options and switch off Software Print Leveling.
    2. Go to Settings > Printer > Custom G-Code and make sure that there is a line containing G29 in the Start G-Code.
    3. Go to Settings > Printer > Features and check Has Hardware Leveling.

    Here is more information about the different types of bed leveling.



  • So if the paper drag method isnt a good idea on robos do you have a better method to "true" the z level?
    Beyond starting a print and when you see a smush you pause and turn the z rods to the left then resume or when you see squiggley lines you pause and turn the z rods to the right?

    Ive heard to do a z home all then turn the machine off and do the paper drag or feeler guage...



Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.