Maker Select Plus RAMPS

  • I purchased aforementioned printer and tried to plug it in to my computer to use with Simplify3D and noticed that it was "not connected." When I checked the Device Manager the printer was registered as RAMPS and it had a Code 10 error with the driver being labeled as MatterHackers. After searching around the interwebs I downloaded the recommended CH340 drivers and tried manually updating which, to no avail, failed to work. Windows 8.1 would say that it had the best drivers installed already. I thought I had fully uninstalled MatterControl prior to plugging in the computer but I have a feeling I didn't. Should I check my registry and remove any MatterHackers/MatterControl entries, reboot, and try again or does this sound like an issue with the board on the printer?

  • Uninstalling MatterControl does not uninstall the driver. To remove the driver manually, go to C:\Windows\System32\DriverStore\FileRepository and delete the mhserial.inf_... folder.

    The mhserial "driver" really doesn't do much. The actual driver is built into Windows. Mhserial just tells Windows to use the driver it already has to communicate with certain devices. It sounds to me like your printer has some kind of hardware error.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.