Top layer incomplete, outer perimeter distorted



  • Hi,

    I have a CTC Bizer Dual which I've been using with MakerBot Desktop (exported to SD) successfully for about two years. I've started using MatterControl two days ago and I love it so far. However, there are some issues that I can't get rid of. Tried with default settings, tried to adjust some other parameters. I've tried to adapt as much of my Makerware configuration as I could.

    One wall of the outside perimeter has bad finish. It's the first side that is printed after infill, so I suspect some retract is happening. However, in the G-Code preview window I see no retract. In the pictures you can see the wall is thinner. I've tried with "Outside perimeters first" unchecked and it improves the situation a bit, however, AFAIK, Makerware also prints outside first.

    The top layer always fails to fill, even though it's set to 3 solid layers. However the bottom looks fine. It might be related to the above problem.


    A smaller issue: can I edit another print in the queue while one is already in progress (via USB) ?


    Photos: https://imgur.com/a/Zcehp

    1. wheel with 3 solid top layers

    2. Calibration box with "outside perimeters first" unchecked, 0.15mm layer height

    3. Calibration box, 0.2mm layer height, default settings

    4. Calibration box, 0.15mm layer, exported from Makerbot Desktop

    5, 6,7 Calibration boxes 0.20mm L.H. with various settings - retract adjustment, "merge overlapping lines" unchecked, "avoid crossing perimeters" unchecked, etc. Those are just some examples, I've already printed >10 of those boxes but they all have the same issues.

    Item 7 is viewed from another side, the badly finished wall is on the right side.


    EDIT: my MakerBot settings https://pastebin.com/bCDc2HeE and MatterControl settings https://pastebin.com/Xkqj2T2x


    Thanks in advance.




  • Moderator

    To me it looks like your printer is under extruding. Have a look at our guide on calibrating Makerbot style printers. Its entirely possible the default steps/mm value in MatterControl is wrong for your printer. We do not have any CTC printers here for testing.

    You can edit other parts in the queue while printing by mousing over the part and clicking the View button.



  • Thank you for the reply, I activated the email notification (I think) but I did not receive an email, hence the long response time.


    I tried to replicate the exact settings I had in MakerBot Desktop. If there's anything I can do to create a profile I'll be glad to help, perhaps it's useful for other users as well. I thought the settings might be translatable between software programs.


    I set the extruding multiplier to 1.1 (from 1.0) but noticed no change. I haven't tried to get higher than that. I will follow the calibration guide.


    I haven't used the program since, but I remember a particular behavior: I'm using SailFish and checked the option inside MatterControl. It sounded to me like the acceleration rate is a bit high, a lot of jerking. I haven't seen any option to play with this setting. However, the parts are dimensionally correct. This "jerking" does not happen when using a generated file (from MakerBot desktop), so it's not strictly related to SailFish.



  • I ran the calibration today: what a change!

    The previous custom G-code command was this: M92 X94.5 Y94.5 Z400 E96 ;sets steps per mm for x3g driver

    After calibration: M92 X94.0 Y94.0 Z400 E112

    Obviously, the extruder step count was raised ~16%, but also the parts were a bit undersized. Checked with a dial indicator the X-axis travel and adjusted so that it was repeatable within 0.01mm.


    For the first time I can print PLA directly on glass! Removed the masking tape and set the Z-offset to 0.05mm. Bed temperature 70C, nozzle temperature 205, if anyone wants to try this.


    I still noticed some issues, all items below refer to the 20mm calibration cube printed in PLA:

    1. top layer is still a bit under-extruded, even at a low printing speed. Should I try the extruder multiplier or raising the E-value in the G-code? Not sure what the difference is

    2. first side wall has the same artifacts as above, I suspect it has something to do with retraction/restart. This artifact seems to happen after a move. I can cure this problem by un-checking "External perimeter first"

    3. the side walls have small protrusions where infill is happening. I suppose there should be a setting like "push-in" - how much the infill should be pushed into the perimeter to adhere - but could not find it

    4. the first layer height is set to 0.3mm, speed to 50%, but the speed seems to apply only to infill(?). Either way, without lowering the global speed the extruder starts skipping on the first layer. Any way to set a global maximum flow rate?

    5. sometimes during experimenting the options "Create raft" and "Air gap" disappeared. After restarting the program they came back.

    6. Z-homing speed at the start of the print is a bit slow


    Thank you again for a great software, I can work around most of the issues but it would be great if there was a "cure".


    Edited above and added a few more points.



  • I will reply to some of my items above:

    1. With active cooling on, decreased speed and 1.05 extrusion multiplier this problem seems to diminish. I think the filament does not have time to fill in the gaps between infills and the missing extrusions propagate up to the surface.

    3. Decreased "Infill overlap" from 0.06 to 0.03mm and this reduced the artefact visibility. Also, with a lower temperature, lower speed and printing the outside perimeter first, the outside perimeter has a chance to cool and not be distorted.

    4. I should have read the instructions, if first layer speed is set to a percentage then it's a percentage of the infill speed (which is set fast in my case). Setting it to an absolute value (mm/s) cures this.

    6. I believe this is a firmware issue. The G1 instruction uses the normal speed while the G28 (home) uses a slower speed (possibly to avoid crashing into the limit switch).

    2, 5, 6 are still up.


    7.1 More of a feature request - x3g files should have a maximum length of 31 characters, otherwise the printer will not recognize the files on the SD card

    7.2 Some way to output M73 - build progress. Also discussed here: https://forums.matterhackers.com/topic/380/problem...



  • Moderator

    1. Changing the extrusion multiplier and the E steps/mm effectively do the same thing. However, the extrusion multiplier can be customized on a per filament basis. For instance, if you are printing flexible materials which require a higher flow rate than normal.
    2. There is an option called extra length on restart, which you can use to help prime the nozzle when unretracting. Another option is to increase your number of perimeters.
    3. You found the right solution with infill overlap.
    4. Typically we use 15 to 20 mm/s for the first layer speed.
    5. Have not seen this before. If you can determine the exact steps to reproduce this issue then we can investigate.
    6. Yes, this is firmware. There is no way to give a feedrate with a G28 command.

Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.