Connecting Robo 3D r1+ to MatterControl or Cura



  • Hey Everyone!

    I have had two 3D printers previously and seeing this my father purchased the Robo 3D R1+, and has had it for about 6 months or more and still has yet to get it working. I can see the USB/ serial port active in the connecting setup process but it will not connect to Matter Control and have literally tried every available combination of options in the software. I am guessing I may need to update the software in the printer itself; however, have not been able to locate files or information about this on the site. I have also tried Cura 2.5 with no success in connecting the printer.

    I am using Linux Mint 18.1 64-bit. The original SD card has Matter Control 1.3 July 6, 2015.

    Thanks in advance!



  • If you can't connect with either MatterControl or Cura, then the problem is most likely with the board. We've seen this occasionally with Robo printers; contact their tech support for a replacement board.



Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.