Need Help resurrecting Kossel Pro

  • My Kossel Pro has been sitting for about a year and I'd like to resurrect it. Today I installed a replacement Azteeg X5 Mini Wifi onto my Kossel Pro 3D printer (Delta). It seems to be working but with a few issues.

    1. When I turn on my machine it halts (red Halt LED blinks quickly). LED 4 is solid, 3 and 2 blink, and 1 is solid. I can get out of it by issuing the M999 command on my machine but I’d like to resolve the issue causing the Fault. After issuing M999 the halt light turns off but LEDs 3 and 2 blink back and forth.

    2. My Viki2 Display does not show anything on the screen it lights up, blue LED works and turns red when the hot end heats up. But no text on the screen.

    3. I also swapped out the OpenBeam hot end for an E3d V6 that I bought from Matterhackers. Unfortunately what I’m finding is my hot end will not reach the target temperature. For example if I set the temp to 230 it will only reach about 202. I’ve run PID tuning a couple of times and updated the values but it hasn’t made any difference. I’ve also tried increasing some of the PID constants but that didn’t work either.

    I’m using firmware-latest.bin from github (here). Version is f27f53d on May 6. For software i'm using the latest build of MatterControl 2.

    I can provide my config.txt file if needed (will need help on how to upload that).

    Appreciate any help from this forum.

  • 1 and 2 sound like Smoothie problems and not anything specific to the Kossel. You might find better luck asking the Smoothie guys about those. They are pretty helpful and active on the Smoothie IRC channel.

    1. You need to find out what is causing the halt condition. Have your printer connected to a computer with the terminal window open, then send it a reset command. It should report any errors through the terminal. Most likely, there is something wrong with your config or something is not wired correctly. After you send the M999, it is normal for lights 2 and 3 to blink. This indicates normal operation.
    2. Again, this could be a config error or just something is not connected right. This may be related to problem 1. Double check your connections on the wiring diagrams from Panucatt.
    3. I would get the other problems sorted out first before you deal with this. Have a look at this guide on dealing with temperature issues.

    If you need to upload your config file, use a service like Pastebin.

  • Thanks. The Panucatt guys had me change the Baud rate in my config file and mattercontrol from 250000 to 115200 and that resolved the halt issue. Viki2 still not displaying anything. Will continue troubleshooting.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.