MatterControl 1.7.0 on Linux - Can't open a file to load - No file dialog

  • Same here.
    Tho' my terminal says:

    "Waiting for a connection on port 52797...
    Web exception occurred. Status code: SecureChannelFailure
    Connected to device channel: ag9zfm1hdHRlcmNvbnRyb2xyLwsSB1Byb2plY3QYgICAiOCSzAsMCxIOQ2xpZW50Q29uc3VtZXIYgICA4LOkiQoM
    Connected to user channel: agxzfmJydWhhLWF1dGhyGAsSC1VzZXJQcm9maWxlGICAgITpiYELDA
    Web exception occurred. Status code: Timeout
    Request Failed: Unable to connect to server"

    The printer is not switched on, which may or may not be relevant.

    You can work around it by putting your models in ~/Downloads/ and selecting "Downloads" in the Library section.

  • Sorry this has taken so long, guys. Can you all try the latest alpha version for Linux and see if that fixes the problem?

    MatterControl Linux Alpha

  • Will do.
    Shan't promise to do it quickly though... 😉

  • I installed it, and it straight away said there is an update to install... :?
    Still not giving me a file dialogue, but I've been having some other issues, so I've not tried very hard yet.

  • It is not the latest "official" version, so it will think there is an update available. Do not install the update.

    What distro are you on and what desktop environment are you using?

  • OK, have re-installed, but still no joy.
    I'm on Mint 18 Cinnamon, but I think I may move to Mint 17: 18 seems full of problems.

  • I just tried it in a completely fresh Linux Mint 18.2 Cinnamon VM and it works fine. What do you get when you run mono --version? If you install the gtk-sharp2 package, does that help?

  • I had the same problem at Mint 18.2. Solved with

    sudo apt-get install gtk-sharp2

    Thanks for the hint.

  • Ok. I will add that as a dependency to the package and make an official release.

  • Apologies again for the delay. I have it installed and am now able to open a file dialogue, but I am unable to log in: the login window sits indefinitely on "Please Wait. Signing in."

    Run through a terminal, it is saying: "Web exception occurred. Status code: SendFailure"

    In case this helps:
    ~ $ mono --version
    Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-4ubuntu1.1)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors.
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    LLVM: supported, not enabled.
    GC: sgen

  • That is a VERY old version of Mono. MatterControl does not support Mono versions before 4.4. There are instructions for upgrading on the wiki.

  • :oops:

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.