Rambo 1.3L fan incorrectly identified. (Solved)



  • have had the rambo 1.3 for several months now to replace the china board i have just upgraded to the e3dv6 and been using it this last week. issue is i now want to add a part cooling fan and have noticed the e3d fan is operating like the part cooling fan.

    so here is the setup e3d plugged into Extruder 0 Heat 0 and fan 0 running marlin 1.1.0 rc7 and repetier for printing with cura slice plugin.

    which pin do i use .for a part cooling fan 2 or just use fan 1? and how do i tell marlin which is which?

    end result i would like the e3d cooling fan to come on when extruder is activated and off when it is switched off at end of print perhaps even once it has cooled to 50c would be better. as for the part cooler to be used as the fan0 is now as i hear it ramp up

    when bridging id assume fan 0 is being treated as the part cooler fan.

    Update

    Ok nm i've figured it out 😛 i was looking in configuration_adv.h of marlin firmware per a guide i was using i should have been in pins_Rambo.h as that was defined in configuration.h with #define MOTHERBOARD BOARD_RAMBO

    #define FAN_PIN 2 (Was 😎

    /**********************************************************

    Fan Pins

    Fan_0 8

    Fan_1 6

    Fan_2 2

    ***********************************************************/

    llastlyin configuration_adv.h

    #define EXTRUDER_0_AUTO_FAN_PIN 8 (was -1)

    #define EXTRUDER_1_AUTO_FAN_PIN -1

    #define EXTRUDER_2_AUTO_FAN_PIN -1

    #define EXTRUDER_3_AUTO_FAN_PIN -1

    #define EXTRUDER_AUTO_FAN_TEMPERATURE 50

    #define EXTRUDER_AUTO_FAN_SPEED 255 // == full speed


  • Moderator

    Glad you got it figured out. I'm sure other people will find this information useful.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.