Robo3D R1+, how to print from SD?

  • Apologies if this has been solved/answered elsewhere, but how do you print from SD card in the printer from Mattercontrol 2.0? MC2.0 is finding the SD card and sees the file, but what is the next step? I tried all available combinations to no avail.
    Any help appreciated.

  • MatterHackers

    You should be able to right click on the file and select print. This will start the print from the SD card.

    alt text

    You can also find 'Print' in the overflow menu:

    alt text

  • Thank you, Lars. That just worked for me. I am not sure why that wasn't showing up last eve, or should I say early this morning. Have to be careful after midnight, I always say.
    I was just able to start the print on the SD card.
    However, when I tried to disconnect in MatterControl, it warned me the print would be canceled.
    Is there a way I can take my computer away and just let the printer print from the SD card?

    Thank you - PPF

  • Update - bad.
    I moved a print to an SD card, inserted in Robo3D R1+.
    I was able to start the print from MatterControl 2.0.
    The printer started, leveled, and printed one outline line across the bed (x-direction) and halted. Just dead stopped.
    I waited a few minutes, nothing changed.
    The idea was to get the print started from the SD Card, and find a point where I could disconnect from the printer in MatterControl.
    While it was idle, I tried to disconnect in MatterControl but warned me the print would be canceled.
    I noticed there was a red light flashing on the Arduino - I could see the light flashing around the USB connector.
    I disconnected the USB Cable -

    The R1+ completely died. What's up with that?
    It will not turn back on, now.
    I have the bottom cover off and don't see anything fried.

    Completely dead.

  • Next Update - turned out the mains fuse blew. I believe the GCode on the SD card differs from that sent by MatterControl over USB, and this ended in the head stalling, pumping current, and blowing the fuse. I read some about the sketchy R1+ power supply and so ordered the MegaWatt authentic version which is 3x the cost of the cheap ones. I think the R1+ has the cheap version in it, to begin with.

  • MatterHackers

    You should be able to just disconnect the printer USB cable, or close MatterControl.

    I will file an issue for disconnecting will printing from SD card should have improved behavior, and do what you expected.

    Specifically, disconnect from the printer without interrupting your print. You should also realize that reconnecting to the printer resets the board and would cancel the print. Just something to think about.

  • @larsbrubaker Thank you, Lars - I think the problem is in the exported GCode file overdriving the print carriage beyond limits and stalling. I haven't gotten to the point where there is a "handoff" from the printer saying "I am OK for you to leave, MC2.0."
    For a different problem (slicing bug), I had to uninstall MC2.0 and load MC1.7. I will try SD from 1.7 and see if it behaves differently.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.