G-Code cannot contain G29 if Print Leveling is enabled

  • Hello there 🙂

    I actually like MC but I've got some issues with the Print Leveling.

    I don't want to use it as my printer has auto bed leveling via G29 (and so I don't like to be forced to complete the paper-calibration after adding a printer 😉 .

    I've enabled Printer->Features: "Has Hardware Leveling" and so the Print Leveling Options hiding.

    But I cannot start printing because of the above error message. There seem to be some point where MC still thinks Print Leveling is enabled.

    I've changed it for every Printer Quality setting tht that may help but it didn't.

  • This set of features can be a little confusing.

    It's probably that you have SETTINGS -> Printer -> Print Leveling -> Require Leveling To Print enabled, so turn that off so you can navigate to OPTIONS and disable the Software Print Leveling, if enabled (though that won't show if you have 'Has Hardware Leveling' checked, so you'd need to uncheck it then go to OPTIONS to disable). Once that's done navigate to SETTINGS -> Printer -> Features and you can enable 'Has Hardware Leveling' if it's not already.

  • Where is this "SETTINGS -> Printer -> Print Leveling -> Require Leveling To Print so I can change it to enabled? I just switched from MatterContol 1.5 to 1.7 now i get the error every time. I did the bed leveling setup with the paper but I want it to work like it did before. If I have 'Has Hardware Leveling' checked or unchecked I get the same error. What am I missing?

  • Found it! all is well. it shows up after you turn off 'Has Hardware Leveling'

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.