MatterControl 2.0 Z Offset?



  • "The sign has been inverted"????? That would explain why my nozzle went through my glass bed last night. I have done a 3 point leveling at least 4 times and it still does not even come close but pushes the bed down and will not extrude. Is this inverted as well?
    Unfortunately I've used MC ever since I got my A8. This is the first time I've had ANY issue like this. Printing has completely ceased. I'm uninstalling and trying the earlier version. Hopefully my settings will still be there. I look forward to using MC again instead of learning something completely new.
    I'm following this chat so Please let me know when the update has been posted.



  • @hardcoremidget One more note. I did find the nozzle offsets but when I hover over it there is a notation that this is for E1 and dual nozzle offsets. That this may not be applicable to all machine. It determines the offset relative to E0. Not the offset OF E0..
    However Lars is correct. It will offset the nozzle of E0 higher if you use a Negative number.llllll



  • Well, just found this on Wiki.
    http://wiki.mattercontrol.com/Automatic_Print_Leveling
    Tips for setting up your printer
    Mechanical Changes:
    Automatic Print Leveling works better if your limit switch is on the top (Zmax). We’ve gotten it to work on printers with the z switch on the bottom (Zmin), but it’s a little tricky.

    G-Code Changes:
    If the limit switch is on the bottom (printer homes to the bed). Add the following G-code after homing.

    G1 Z1 ; raise the extruder to be 1 millimeters above the bed.

    This code will help prevent the extruder from bumping into the build plate when it first starts moving.

    Mechanical Changes:
    Automatic Print Leveling works better if your limit switch is on the top (Zmax). We’ve gotten it to work on printers with the z switch on the bottom (Zmin), but it’s a little tricky.

    G-Code Changes:
    If the limit switch is on the bottom (printer homes to the bed). Add the following G-code after homing.

    G1 Z1 ; raise the extruder to be 1 millimeters above the bed.

    This code will help prevent the extruder from bumping into the build plate when it first starts moving.
    As of today, I still cannot get Print leveling to work correctly on my A8.


  • MatterHackers

    Hey @HardcoreMidget

    So at the moment both Lars and I will not know how to help you, to help you out we are going to need you to provide information to us. I see the issue is that the nozzle is touching the bed but what is the set up of the printer? Do you have a BL touch installed in the printer, if so have you calculated the offset from the probe to the nozzle and applied that value in MatterControl?

    I presume from you linking the Z-Endstop information that the AnetA8 has the home switch at the base of the printer so the nozzle homes to the bed? If you could clarify this for me I can see how we can set you up.



  • @michael-petitclerc Thank you Michael, Generic A8 with 4 corner bed adjustment, No BLTouch. Z stop is at bottom and homes there. I have added the Z= -1.25 to the Extruder offset and that seems to be working. I'm assuming it has to be a negative since It's referring to the Top of the Z position even though 0 is at the bottom.
    I've repeatedly done the 3 point Leveling with Leveling on and turned leveling on after doing Leveling but it makes no change to the Z position as it moves across the bed so I don't think the Leveling is active. I've also Re-Sliced it after Leveling The leveling shows the nozzle touch position + paper at .119, .119 front and .126 back. Am I correct in assuming that the Z position should change by those differences as the nozzle moves across the bed? That does not happen from watching the Z position on the screen and printer.


  • MatterHackers

    You would be right that our nozzle offset from the bed is calculated from the top because of how our Pulse printer is set up. (Unless I am wrong and Lars drops in to tell me otherwise ;D)

    I believe that if you input values for bed leveling in MatterControl then you should see the Z height adjust mid print to compensate. I am not sure if there is a significant range it needs to meet to actually apply an adjustment but you should see it. An easy way of seeing it is to run a print with raft and the interface layer from part to raft will easily show the compensation on larger parts. Only down side to this test is that you need to enable raft.



  • The global Z-offset is now in the nozzle offsets section. Got that.

    However, all of the responses above are somewhat confusing as to the value to put in for Z. So, to clear up any confusion:

    QUESTION: A positive value for Z-offset increases or decreases the distance between the bed and the nozzle?

    In most software I've used, a positive value indicates the distance between the nozzle and bed is increased.



  • The tool tip should be changed to not make such a directed statement about the Extruder offsets referring only to the first extruder. I only have one and I used the previous z offset all the time. I had to do this search to find out how to set the offset on the new version and find out that it was a negative value also. When I have time, I will take a look and try to understand why there would be separate z offsets for more than one extruder. X and Y is obvious... I would think that the Z on all extruders would have to be the same, so having Z grouped this way makes no sense to me.


  • MatterHackers

    @SteveThatcher

    In the case of the upcoming Pulse Dual Extrusion we have (Release TBD) the right nozzle articulated up and down so at any time it may be 5mm above or below the left. So when we go to start the same layer on the right hotend, the Z-offset will need to be adjusted.

    My apologies to the rest of the group here on the whole Z-Offset value issue, we are still working on sorting out all the settings and tooltips.



  • All those changes and confusions with the Z-Offset was one of my reasons to move to a different slicer(Slic3r) and just use MC to add the bed leveling and send the Gcode to the printer so to do the power recovery and filament out detection etc when it works. I miss some of the 1.75 stuff.



  • @michael-petitclerc ok, so i'm back to a different problem. My Z axis is now going to -42 and adjusting positive after doing the auto-Leveling procedure. I have my Z offset set to -.62, per your previous comment that the z offset is configured from the top of the printer. So a -negative number should raise the nozzle for the nozzle offset. It's not doing anything as it did several weeks ago. (I'm been out of town for about a month and came back and tried to print something........The z offset is way off from what it was before I left.



  • @jeff_reynolds_beta As per his previous respose Michael and Lars are writing code for MC using a printer with the Z home switch at the Top of their machine so the negative number moves it UP towards the Z=0



  • I had a similar issue before - try the following.
    1.) Set up a new printer (I called mine "New Pulse) that makes sure you don't get messed up by some legacy settings from a prior version
    2.) Then do the setup (bed level etc) and try a print. While its printing use the control pane and adjust the Z-offset (print something big with lots of brim so you got time to do it.
    3.) once you got it set - kill the print as there is no need wasting filament (or you could have set "print first layer only" if that still exists.
    4.) note the setting in the controls for the Z-offset - write it down and reverse the sign

    1. set it to 0 by hitting the X in controls (as it gets set to 0 anyway the next time you exit the program
      6.) go to the z-probe offset and put the value in with the reversed sign that you wrote down.

    For whatever reason items that are removed from the UI are not always removed from the settings store. So the old "z-offset" that was removed becomes invisible but it is still there - happened to me. Alternatively you can export the settings and hunt for anything z-offset in the export file and set it to 0 and then import it but that gets hairy. I had to wipe all my settings 2x so far (set up a new printer or restore factory defaults). So make sure you got a written backup somewhere



  • I have a Robo3d R1+ and this new update totally killed all my settings. Nothing imported from the previous version (filament types and settings).

    Additionally like everyone else has stated the auto bed leveling feature no longer works. After probing the bed the nozzle basically sits on the glass and cannot be adjusted PERIOD! I've gone into printer/general and tried inputting Nozzle Offset to 1.6/-1.6 ..Nothing. I've gone into printer/Features/hardware and tried activating (turning on) has z prob and has Z servo.. Nothing!

    The only way that I can print using MC is to run a print with a skirt and during the skirt print go into controls/movement and raise the Z height manually to 1.6 using the Z+. It has taken me days to figure this out and I only found this out through trial and error finally getting the height right.

    My only other thought would be to program a G1 Z lift into the Start G-code right after probing the bed but in doing that you no longer have an accurate print because the bed is not perfectly leveled and I'm not sure if it will print with the same static number now in place.

    I'm running MC version 2.19.2.10169 stable



  • I had the same thing here is the solution

    Go into Printer
    Then features
    Expand the Leveling section
    There is an item under leveling right under Start height that say Probe -Z offset if you hover over it it says "if you do manual leveling its the thickness of the paper. Set that to 0 as the default is 1.6 - I guess really thick paper. Then your offsets will work more predictable

    Also remember the offset you set in controls will go away after you go out of the program. The whole Z-offset mess was a reason I started to look into other slicers and yes its a pain but at least more predictable and I get some other features. So I slice in slic3r and then run it through MC for bed leveling at least until they improve MC and make it more usable (including volumetric printing) or I figure out how to bed level manually in slic3r as I am not replacing the BLTouch for a 4th time



  • I tried that probe Z offset in leveling as a Z offset and that does not work what it does is include it into the offsets from bed leveling and then apply it in runtime. You could probably go and edit the 3x3 mesh results table and +/- the 1.6 depending on how the handle that currently there . But I think its easier to set it to 0 and relevel the bed.



  • @mpirringer your solution of adding a new printer solved my problem.



  • @larsbrubaker The note in MatterControl says that this setting is ONLY useful for multiple nozzle printers.



  • Well it works sometimes


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.