MP Select Mini V2 won't connect to MatterControl

  • Hello,

    I'm trying to connect my Monoprice Select Mini V2 to MatterControl using a USB but it seems to get sort of hung. I can still click the back button or cancel but it doesn't seem to connect.

    I used the setup wizard, followed the steps, and when I click "Connect" it just says "attempting to connect" but after a few minutes nothing changes.

    I left it for 20+ minutes, tried the manual setup, and I installed the Arduino drivers, I updated MatterControl but it still doesn't connect.

    My printer's firmware is 40.156.2 and I'm on Windows 10. Do I need to update my printer's firmware to V41? Install another driver?

    Thanks in advance,

  • Update:

    I left it "attempting to connect" with the setup wizard for about 30 minutes, canceled the process, closed MatterControl, left my printer plugged in, opened MatterControl, and it auto connected.

    I don't understand how it connected this time but it did. I was even able to start the print from MatterControl so it seems to have connected without issue.

    So technically my issue is solved even though I don't know how. I'm not sure leaving it to connect to 30 minutes solved the problem. Any idea what could have worked so I know for future and for other users who may be searching for answers as well?

  • MatterHackers

    I would guess something strange happened with our ability to find the serial port. Windows sometimes looses touch with them and then we don't get notified.

    Closing and re-opening was probably the fix.

    We'll keep looking into this to see if it can be improved.

    Thanks for the feedback. Glad it's working now.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.