Trouble with Robo3d R1+

  • This is my first 3D printer and like it a lot. I am a novice so may be asking some simple questions.

    When I got this I ran the standard general tests over a couple of days and everything was fine. Worked great and produced what I expected.

    I hadn't used it for a few days and went to print and the filament broken at the filament input on top of the extruder. I pulled what I could out of it but there was a small piece left inside. I re-fed the filament back through the the filament input and fired it up.

    Problems seen:
    o Filament mechanism is moving as expected, but filament is not being pulled.
    o Z-Axis is floating no matter what I try setting.

    What I have tried.
    o I have reset the filament breaking off the end and reinserting but nothing is happening.
    o Do I need to disassemble the nozzle to clean it? If so, how?

    o I have tried several things and can Set Home and all switches are Triggered in G-Code as expected. When I run a print the nozzle floats above the bed about 1mm. I did find this article, but my sensors are not misaligned like what is depicted.
    o I have reset EEProm back to Factory Defaults and saved, but nothing actually changed in the settings so nothing appeared to be out of spec.
    o I have manually tried setting the threaded rod height for the sensors and this got me to 1mm, prior it was 6 or 7mm.
    o When I set Home the Z-Axis is shown as -0.90. I do not know if this is correct or not.
    o Has Hardware Leveling is selected.
    o Start G-Code has "G29 ; Probe the bed" defined.

    All settings are still default, Bed Temp = 50, Extruder Temp = 210, Filament = 1.75.

    Thanks for any help in advance.

  • MatterHackers

    Hey Caveman,

    It sounds like the filament already loaded into the hotend is more than likely blocking the fresh filament from loading in. The filament patch might not be constricted enough ti allow for the new filament to simply push through the old material so the new material may be pushing past the old and jamming up. I would recommend removing the PTFE tube and pulling the old material, if the old material is caught below the PTFE you will have to disassemble the hotend.

    I am not sure if this video will match the same connections on your system but I thought this video was the better of a few I saw.

    For the Z offset, it sounds like you may need to check the printer's total build volume by having the Z axis move to the bed and seeing what the onscreen prompt is telling you as that height. From there you will see if this value exceeds the machines preset limits. If the limit is exceeded then you are looking at the limit switch being out of place. However if the limit switch is within range you are looking at some sort of offset in the software being applied in the slice. check your slicer and see if there is some offset being placed.

    If you are using a Probe system, it may not be calibrated to the correct offset when referencing the nozzle. In our Pulse printers, when a user runs the Bed level probe command and does not run a Nozzle offset command there can be a 3-4mm offset.

    Give these a shot and see how we are looking.

  • Thanks. I think that video might be helpful for the filament issue.
    I need to dedicate some time to this and get it working again.
    I found several other maintenance type pages here as well that I need to look over.

  • MatterHackers

    Yeah, sitting down and saying "I'm going to work on this printer" tends to be the hardest part. For me the process can be therapeutic after the initial 15 minutes of getting started. Those initial 15 minutes tent to be filled with unhappy remarks as I figure out the plan of the night!

    Let me know how it goes.

  • Finally got to this issue. Took forever get motivated and find the time for it.

    Not sure what happened though but got it working again.

    1. The filament - I actually found a great article for this (here). Much easier than anticipated.

    2. Reinstalled the MatterControl software since there is not Factor Reset in it. Started printing right away. Trouble is I never changed anything in the settings (because I don't know what anything does) so not sure what caused the miscommunication from the software.

  • MatterHackers

    In case you ever need to reset your settings again you can find it here:

    alt text

    You can also find all the individual settings you have changed by clicking "View Just My Settings"

    alt text

    Great to hear you got it working.

  • Yeah. Me too. Glad it was something simple.

    On to another question, what version/license level software are you running? My interface looks like a paired down version of what you have and I am running MatterControl 1.5 - ROBO 3D and there is no reset anywhere I can find and a lot of your listed menu drop-downs are not available to me.


  • MatterHackers

    Hey @caveman You seem to be running the older version of 1.5. That is a bit older than the version before 2.0. Im afraid to say it but you are a bit in the Dark Ages (please forgive my pun there I could not avoid it).

    You can find the upgrade to MC 2.0 here Download the 2.0 version and gaze at the wonders of the future! Or just be amused at the new layout and features.

    Let me know if you have any trouble finding something in the new version!

  • Interesting.

    That was the version (1.5) that I just downloaded and seemed to be the latest version available from the DL site that it directed me for downloading.

    Got your link though and downloading now. Thanks.
    Will install after this latest print is done.


    alt text

    Thanks again to everyone that responded.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.