The printer stops printing when printing bridges.



  • Hello, I have a problem. Very often, the printer stops printing in the vicinity of bridges. What could be the reason?



  • Why is this happening?

    N25355 line twice?


  • Moderator

    What printer do you have and what firmware is your printer running?

    What we have here is a little communication hiccup, followed by your printer speaking a language that MatterControl does not understand. Occasionally there are problems sending commands to the printer, in which case the printer will ask for the last line to be sent again. This normally looks like

    <-Error:Line Number is not Last Line Number+1, Last Line:6429
    <-Resend:6430
    

    However in your case the printer is speaking Polish, while MatterControl expects English. So MatterControl does not know that it has to send that line again and the printer refuses to continue.



  • Printer eko3d M260. Ramps and ARDUINO MEGA2560.


  • Moderator

    What firmware is it running? Marlin, Repetier, or something else?



  • Marlin


  • Moderator

    It is apparently running a very old version of Marlin. This behavior was fixed in Marlin several years ago. My recommendation is to update to a newer firmware. This is unlikely to be fixed in MatterControl anytime soon, since we would have to check for these messages in every possible language and that would add a lot of overhead.



  • I installed the latest Arduino and Marlin. Unfortunately went to print by MatterControll. As regards the working Pronterface approx.

    I printed element cut by Matter and Matter actually works but does not print. Is it compatible with the latest Marlin?



  • Alpha version does not work, it works Beta !!! 🙂



  • alpha version works with a long delay. for every step I have to wait a few seconds. The beta version does not work anymore. This happens the same as before 😞




  • Moderator

    That is known issue with the alpha version of MatterControl. It is unrelated to the previous problem.

    https://github.com/MatterHackers/MatterControl/issues/1755

    For now I think you should revert to the stable release of MatterControl (1.6.1).



  • The original error seems to be related to https://github.com/MarlinFirmware/Marlin/issues/36... Using Marlin 1.1.0 RC8 with MC 1.6.1 I also have this issue even if as it looks Marlin and MC seem to be able to deal with it. If it happens it will cause a tiny delay that may be the reason for the bridge issue.

    With MC1.6.2 the M110 N1 seems to cause the problem. Using a terminal and replaying the commands manually M110 acts strange:

    M110 N0
    ok
    N1 M105*38
    Error:Line Number is not Last Line Number+1, Last Line: 2
    Resend: 3
    ok
    echo:Unknown command: "ok"
    ok
    Error:Line Number is not Last Line Number+1, Last Line: 2
    Resend: 3
    ok
    N0 M110 N1*124
    ok
    N2 M115*36
    FIRMWARE_NAME:Marlin 1.1.0-RC8 (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:ANYCUBIC EXTRUDER_COUNT:1 UUID:8112eb85-d15b-460e-8089-f83b108660bf
    ok
    N1 M105*38
    Error:Line Number is not Last Line Number+1, Last Line: 2
    Resend: 3
    ok
    N0 M110 N1*124
    ok
    N1 M105*38
    Error:Line Number is not Last Line Number+1, Last Line: 1
    Resend: 2
    ok
    N25 M105*16
    Error:Line Number is not Last Line Number+1, Last Line: 1
    Resend: 2
    ok
    M110 N0
    ok
    N1 M105*38
    Error:Line Number is not Last Line Number+1, Last Line: 1
    Resend: 2
    ok

    From the Marlin documentation, the short form w/o line number should work without checksum, but in fact, does not. So I would assume the M110 command to be broken, maybe somewhere on the road to or from RC7.

    Guess a good suggestion for Mattercontrol 1.6.2 might be to revert to the communication as it was in 1.6.1 and maybe reduce the M105 frequency a bit to relax communications.






Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.