Software Leveling broke when I upgraded from 1.6 to 1.6.1

  • I updated to Vs 1.61 and the printer lost it's leveling data (the head hit the glass when i went to print)

    I tried running the Calibration - but it was not sending the head to the correct positions.

    I have the Rostock Max V1 (with mods so it is basically V2),, The bed is 280x280 Delta

    I use th3 13 point leveling. I opened the Leveling Settings dialog and it opened a window with the correct title and the SAVE and CANCEL buttons, but, the body of the window was blank. No position settings were given, no table, nothing, just blank.

    I went to settings and chose the 7 point leveling option, then the 3, then hit default, etc, etc, it remained the same.

    So, I downloaded 1.6 and reinstalled it (rather than the 1.61) and it is still broke.

    But, at least the Leveling Settings window shows the 13 positions - the positions are wrong.

    I am not sure what the default positions are supposed to be for the 280mm delta bed

    What it gives me is


    1 X140 Y0

    2 X140 Y0

    3 X140 Y0

    4 X0 Y140

    5 X0 Y140

    6 X0 Y140

    etc, it repeats the position 3 x - so basically it gives me only 4 points and center, not 12 + center

    I need to reset this to the correct positions - and why did this happen when i did the update?

  • Well, I got the correct positioning coordinates, used a Cad program for that. But, not good that i did a simple update and it messed it up.

  • nope forget it, it is still broke. After entering all the correct 13 position coordinates, when i ran Calibration it still goes to the wrong locations, same as before, where it repeats each location 3x

  • It sounds like perhaps the profile import wizard did not run correctly.

    1. Delete (or temporarily move) the Profiles folder at C:\Users\$USERNAME$\AppData\Local\MatterControl\Profiles (AppData may be hidden) in Windows or Mac OS X and Linux: ~/.local/share/MatterControl/Profiles (.local may be hidden)
    2. Re-launch MatterControl 1.6.1 and it should run the profile import wizard which will pull existing data (including your leveling data) from the old database used in versions before 1.6 and allow you to sync those profiles to the cloud.

    Alternatively, you can use a SQL database viewer to access the coordinates inside the database and manually insert them into a new profile. Let me know if the above instructions fail and we can try this if needed.

  • Sorry took so long -

    Nope - I did what you said, renamed the Profile dir re-launched Mattercontrol 1.6.1 it ran a wizard, I think for setting up the cloud accnt, which was already set up, but i didn't see a profile import wizard.

    When I first viewed the Level Settings window, it showed what looked like older Level settings But, when i printed it was off, so I ran the Calibration to redo the values, and it did the same thing,

    moves to the first location, set the height, then instead of going to a different location, it stays in same location for 3x, etc. When i exited the Calibration I viewed the location settings again, and now it was blank like before.

    I noticed that Leveling was turned off, so I went to turn it on and it crashed, giving an error box unhandled exception saying that the Index was out of range - must be non-negative number

    So, now I am unable to print anything...

  • additional note: When i reboot the program and turn on Leveling - it is working now and prints ok i guess the other time i tried to print leveling wasn't turned on

    But when i try to run Calibration it still is not going to the 13 points, it still is stuck on 3x at same location. Then I cancel Calibration and it turns leveling off - at that point when i hit button to turn leveling back on - it crashes w/ the out of range index. BTW I have uninstalled MatterControl and reinstalled it already

  • @unltdsoul said:

    But when i try to run Calibration it still is not going to the 13 points, it still is stuck on 3x at same location.

    The process for measuring each point has three steps, making a total of 39 total clicks to get through the wizard when it is set to take 13-point leveling. Each has a rough (1 mm at a time), medium (0.1 mm) and fine (0.01 mm).

    See this other post for steps to correct for the "too low" error you're getting:

    It's surprising that renaming the Profiles folder did not cause the import wizard to run. Can you confirm the Build Number of the instance of MatterControl you're running?

  • Ryan -

    I know how the calibration works, or is supposed to work, I've ran it many times before i did this upgrade. I know that it moves Z in 1mm .1 and .01 mm What I mean, is what i hinted at in my first post, it will start with location X140 Y0 and after setting that location - with all three depths 1mm .1 and .01 it should go to the next location, but, it doesn't - the head stays in the same location and starts over with the 1mm .1 and .01 it does this for 3x then it jumps not to the next or 2nd location, but to the 4th location as i showed in my first post


    1 X140 Y0

    2 X140 Y0

    3 X140 Y0

    4 X0 Y140

    5 X0 Y140

    6 X0 Y140

    where position 1 is correct, x140 y0 but position 2 should be

    2 X121.24 Y70
    3 X70 Y121.24
    4 X0 Y140

    So, instead it stays at location 1 for 3 times, then jumps to 4th position. Again, i am speaking of counting the 1mm .1 and .01 settings as being one location setting.

    I have tried setting the leveling to 7 positions and 3 and back to 13 but it doesn't change the way it is working.

    Previously, after i first did the upgrade, when i pull up the Leveling Settings window (using the edit pencil button next to the Software Print Leveling under Calibration in the Options menu - it actually displayed those incorrect position values, where it shows

    1 140 0
    2 140 0
    3 140 0
    4 0 140

    But, after doing what you told me as long as i don't try to run the Calibration Configuration... it now will display in the Leveling Settings window the correct locations, and when i print it is doing the leveling OK

    But, if i try to run the Configuration then it goes to the wrong locations, staying 3x at the first location, then jumps to the 4th location... etc. When i hit cancel of the configuration and try to view the positions again by opening the Level Settings window, that window will now be blank, not listing any positions at all. And, when you cancel the configuration the program turns leveling off, so if i try to turn it back on, after having tried to run the configuration the program crashes with the index out of range error

    Definitately, something is wrong

    Build is

  • @unltdsoul said:

    I know how the calibration works, or is supposed to work

    Okay, good, so we're on the same page there. It sounds like there may be a bug that is causing the problem, but I do not know the exact cause.

    At this point there's two main paths we can take: 1) I give you a workaround solution to get you back to normal with 1.6.1 and go from there, or 2) we try to track down the bug that is only going to be an issue for what I assume is a small number of users who are having difficulty with the upgrade.

    The first option is fairly straightforward; the second is probably more hassle than it's worth and you will probably still have to use the workaround if it's decided that corrupt data has something to do with the problem.

    I offer the following workaround as a solution:

    1. Close any open instances of MatterControl.
    2. Move the folder located at C:\Users\$USERNAME$\AppData\Local\MatterControl to another location. Doesn't matter where, just not in the same place-- and do not delete it.
    3. Open MatterControl 1.6.1, which should be like a fresh install with nothing configured yet.
    4. Proceed through the Setup Wizard: sign in, and allow MatterControl to sync the profiles associated with your account.
    5. Once syncing is complete, create a new printer using the existing Rostock profile that is closest to your configuration. Adjust settings as necessary.
    6. Navigate to the Software Print Leveling section in OPTIONS, and quickly click through the leveling wizard. You do not need to measure carefully; you are tricking the system into creating data that you will replace with your existing data.
    7. Download and install SqliteBrowser:
    8. Open the MatterControl.db file located in the directory you moved in step 2.
    9. Navigate to the 'Browse Data' tab and select the 'Printer' table. In it you should see a table of your printers, and related leveling data is contained in the 'PrintLevelingJsonData' column in JSON format.
    10. In MatterControl, in the Software Print Leveling section in OPTIONS, click the pencil icon next to the words 'Software Print Leveling (enabled)' and edit the values to match the values in the database table.
    11. If you had any custom G-Code you want to recover, it can be found in the 'SliceSetting' table in the same database.

    You should now be ready to run a print with the new profile.

  • Thanks - I havent done it yet, will try to get to it later today, maybe tomorrow -

  • Okay, great. Just so you're aware, we're out of the office until Tuesday so we will reply then if needed.

    Have a great holiday weekend!

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.